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Overview 
This Technician’s Installation Packet (Tech Pack) outlines the responsibilities of the local 
technician, and how support can assist. This document covers recommended hardware, 
network, and software configurations. It also contains information on configuring OrthoTrac, a 
Sensei product, as well as migrating the data to a new server, and maintaining and backing up 
data and files for OrthoTrac. 
OrthoTrac is a critical systems application that must be running every day with as little down 
time as possible. In addition to the application, the hardware is critical to ensuring the stability of 
an automated practice management system. Our hardware recommendations follow what has 
been tested. Carestream Dental is only able to test OrthoTrac in a limited number of 
environments. OrthoTrac support will work with you as best as we can if you are not following 
our recommendations, but we will be limited in modifications we can make to get OrthoTrac 
working in environments that do not meet the requirements listed in the current Systems 
Requirements. 
Carefully read and follow the installation instructions in the Installation Guide and 
recommendations contained within this Technician’s Installation Guide. If you have any 
questions, contact OrthoTrac support. 

Technician Acknowledgement 
The local technician is fully responsible for the configuration, installation, and maintenance of 
the client's computer network. Our company does not support the installed network or its related 
issues, including printer installations or operations. 
The local technician is fully responsible for making sure the hardware is configured and the 
client is trained to save and restore a backup of the OrthoTrac data and all necessary files for 
OrthoTrac. Since there are many types of backup programs, OrthoTrac support does not train 
offices on configuring the backup system or restoring a database. If an office must send data to 
OrthoTrac support for in-house analysis, send backups on external hard drives / flash media, or 
internet transfers. No other forms of backup media are accepted for data analysis. Addendums 
to installation documents will be made as necessary. 
The local technician is fully responsible for the support and maintenance of the client's computer 
network system. Give your clients your contact information and specific instructions to contact 
you first for system-related problems. Any questions about optimizing the network environment 
for use with OrthoTrac products are welcome. It is recommended that you be familiar with the 
client’s Windows operating system and carry an MCSE (Microsoft Certified Systems Engineer) 
certification or equivalent on staff. 
OrthoTrac representatives are highly trained and capable of assisting you to ensure a smooth 
software/hardware installation and systems upgrade. When contacting support, be sure to have 
the client’s account or phone number ready. 
Questions can be emailed directly to orthotracsupport@csdental.com or call support at 
866.722.2567. 

mailto:orthotracsupport@csdental.com
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System Requirements, Installation Basics, and Configuration 
Before installing OrthoTrac or migrating the data, review the following items in the Resource 
Library (gosensei.com): 

• System Requirements – Review before proceeding to ensure the hardware meets or 
exceeds the current requirements. For questions on versions of Windows, peripherals, 
third-party software versions, and other software requirements, reference the OrthoTrac 
system requirements. 

o Locally Hosted or Shared Server System Requirements 
o OrthoTrac Cloud System Requirements 

• Configuration Guide – Review the current configuration recommendations. 
• Installation Guide – Follow the steps to perform an upgrade or new installation. 

OrthoTrac Installation Guide 
This guide is meant as a supplement to the OrthoTrac Installation Guide. The installation 
guide contains the most recent step-by-step instructions. In addition to the Resource Library, a 
copy of the OrthoTrac Installation Guide is located in the following locations: 

• Documentation\Manuals\OR200_OrthoTrac_InstallationGuide.pdf on the installation ISO 
• OMS\OnlineDocs\OR200_OrthoTrac_InstallationGuide.pdf on an existing server 

installation 

Self-Installation Recommendations – Installer File for Locally Hosted 
Offices 
Beginning with version 15.1.3, the OrthoTrac Installer is available for download via the Dental 
Practice Management Software Download Service. 
Important: The file on the Dental Practice Management Download Service is for your 
practice only and is unique to your login. The download will expire after 24 hours. 

1. Save the OrthoTrac Installer file to the server. 
2. Follow the procedures in this document to install or update OrthoTrac. 

Download the Installer Files 
1. On the server, go to softwaredownload.csdental.com. The Dental Practice Management 

Software Download Service login window is displayed. 
2. Enter the Customer ID and Zip Code. Your Customer ID is between 6 and 10 digits 

and is located on the Support Schedules, Annual Contract Renewals, and any 
Invoice. 

3. Click Submit. The installer file download is displayed, along with instructions. 
4. Click Download and save the file to the default download location. 

STOP! Before you proceed, verify any 3rd party vendors used by the office are compatible with 
the version of the DPMS software downloaded. It is the office’s responsibility to check with any 
3rd party Application/Software companies to ensure that it is compatible with the new version of 

https://gosensei.com/pages/resource-library
https://gosensei.com/pages/resource-library
https://cdn.shopify.com/s/files/1/0573/0821/7483/files/OrthoTrac_v15.3.1_System_Requirements.pdf?v=1691781859
https://cdn.shopify.com/s/files/1/0573/0821/7483/files/OrthoTrac_v15.3.1_Hosted_System_Requirements.pdf?v=1691781859
https://gosensei.com/pages/resource-library
https://softwaredownload.csdental.com/en-US/
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DPMS/SQL software being installed. Carestream Dental is not responsible for incompatibility 
issues with 3rd party vendors. 

Basic Installation Steps 
1. Install OrthoTrac on the server. 
2. Share the parent folder of the installed OMS folder. 
3. If the office is using Carestream Dental Orthodontic Imaging, install imaging on the 

server. 
4. Restore any existing data. 
5. Map workstations to the shared folder on the server. 
6. Install OrthoTrac on the workstations. 
7. If the office is using Carestream Dental Orthodontic Imaging, install imaging on the 

workstations. 
8. Install OrthoTrac on any Remote Desktop Services servers. 
9. If the office is using Carestream Dental Orthodontic Imaging, install Orthodontic 

Imaging on the Remote Desktop Services server. 

Office Configurations 
There are several ways OrthoTrac can be configured. Generally speaking, an office, regardless 
of the number of locations, will want to keep all of their locations together in one data set. In 
cases where the client wants to house multiple data sets to further separate their offices, 
assistance may be required from a support representative for installation and support. 

Single Locations 
A single office location is typically configured with a server that houses the OrthoTrac data and 
multiple workstations that run OrthoTrac locally and connect to the OrthoTrac server over the 
network. The server runs an instance of Microsoft SQL Server; by default OrthoTrac v12 and 
v14 will install MS SQL 2008 Express. Version 15 will install MS SQL 2014 Express. We 
recommend allowing OrthoTrac to install the Express edition of SQL. If you will require the use 
of a full version of SQL during the installation process, you will be presented with an option to 
direct OrthoTrac to use an existing SQL instance during the server install. The server also 
houses a number of files that are accessed by the workstation. 
If the practice will be using Carestream Dental Orthodontic Imaging, we recommend having a 
separate server to house the imaging data. This should be a separate physical server. It is 
preferable to have two individual servers house the data for both programs than to virtualize 
both the OrthoTrac and imaging servers and run them on the same host. 
Note: SQL Server Express Editions are restrictive on database size and RAM/CPU usage. 
These restrictions could affect performance. Consult Microsoft for SQL Server version 
specifications to make sure that an Express edition is right for your practice. 

Multiple Locations 
Clients who have multiple locations and want to share a single data set between the locations 
will need to use remote access software to connect the locations. We recommend installing the 
OrthoTrac data server in the largest office, along with a Remote Desktop or Citrix server, and 
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have remote users connect to the server through Remote Desktop Services to run OrthoTrac. 
The remote office does not actually run OrthoTrac locally; the application is run in the main 
office on the Remote Desktop server. Carestream Dental has not tested running OrthoTrac 
between two offices using a VPN connection. 

Imaging in Multiple Locations 
Adding Carestream Dental Orthodontic Imaging with multiple office locations increases the 
variables and methods of setting up the office. We recommend discussing the options with 
Carestream Dental Orthodontic Imaging support or implementations team prior to setting this 
up. Some questions to consider before contacting support are: 

• Will images acquired in one office need to be accessible in all offices? 
• What digital imaging equipment will be used in each office? 
• What internet connections are available in each office and what is the bandwidth? 

Installation and Migration 
Whether a client is a new or existing customer, before data can be applied for an office, the 
server that will house the data must have OrthoTrac installed in the proper location. OrthoTrac 
must be installed before Carestream Dental Orthodontic Imaging is installed. This enables the 
two programs to communicate properly. 
It is also recommended to call support a few days before your planned update or install to 
schedule a representative to work with you during the transition. When migrating data, we also 
recommend decommissioning the old server if at all possible, or at least, stopping services for 
the SQL instance running OrthoTrac. 

Installing OrthoTrac On a New Server 
All workstations must be able to access the OMS parent folder on the server. If you do not want 
to share the root of the C:\ drive on the server, be sure to change the destination folder during 
the installation process. Do not install to C:\OMS then move folders. This will break the 
ability for a workstation to create a backup copy of the OrthoTrac data and will cause problems 
updating the server. For instance, if a client wants to install OrthoTrac on D:\data, you must 
install OrthoTrac to D:\data\oms and D:\data\oms-spec, sharing the D:\data folder on the 
network. Then map the network drive on the workstations (generally U:\) to the shared data 
folder on the server. 
Before installing, OrthoTrac searches all local hard drives for an existing installation of 
OrthoTrac. With a new server install, it is recommended that you wait for this process to 
complete. There is a work around noted in the Server Updates section of this document. 
If you are using Windows Firewall, be sure it is on when OrthoTrac is installed. There are 
exceptions that must be made for SQL. These exceptions are made automatically if the 
Windows Firewall is on during installation. If you are not using Windows Firewall, then you will 
need to manually add exceptions for SQL to the firewall. 

Migrating an Existing Version 11 or Higher Server to a New Server 
1. Verify all users are logged out of OrthoTrac. 
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2. Start OrthoTrac on the server. 
3. Have a staff member log into OrthoTrac. 
4. Select File > Prepare Backup. 
5. Wait for the Prepare Backup process to complete. 
6. Select Options > Environment. 
7. Note the Server Path (default is C:\OMS) and Database Prefix (default is Main). 
8. Browse to the server path\backup\Most_Recent folder. 
9. Verify the backup files exist for each database. 

The file name structure is prefix_dbname_yyyymmdd_xxx.bak. The prefix is the 
database prefix from environment. There are five databases for OrthoTrac, named 
Audit, CommCat, DelOMS, OMS, and TxCard. The xxx is the backup count; the first 
backup of the day is 001. For example: Main_OMS_20130505_001.bak 
If the client is using Carestream Dental Orthodontic Imaging v10 or higher: 

• Run pwisetloc.exe. 
Note the SQL backup location. 

• Browse to the SQL backup location. 
• Verify there is a Most_Recent folder that contains a 

prefix_PWImage_yyyymmdd_xxx.bak file. 
10. Close OrthoTrac. 
11. Right-click on the key icon in the system tray. 
12. Click Exit PracticeWorks Server. 
13. Install OrthoTrac on the new server. 
14. Copy the following files from the old server to the OMS folder on the new server: 
• \OMS\pwsvr\pwlf.dat 
• \OMS\*.000, C:\OMS\*.001, C:\OMS\*.002, etc. 
• \OMS\filelist.nrl 

Note: By default, files with filename extension, such as .000, .001, .003 and .nrl, as 
listed above, are set to be hidden by Windows. You will need to set Windows to view 
all files including hidden or system files in order to see these files. 

• \OMS\Fingerprint.mdb 
• \OMS\roll*.txt 
• \OMS\AuditTx.dat 
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15. Copy the following folders from the old server to the OMS folder on the new server. 
Some of the folders listed may not exist on the old server: 

• \OMS\ACH 
• \OMS\Backup 
• \OMS\Daysheet 
• \OMS\Docs 
• \OMS\ECS 
• \OMS\Epayment 
• \OMS\ICCPS 
• \OMS\Snapshot 
• \OMS\ToothCht 
• \OMS\Orthometrics 
16. If the new server will be the imaging server, copy the following folder from the old server 

to the OMS folder on the new server: 
• \OMS\image 
17. On the new server, run the URestore utility located in the c:\oms-spec\utility folder. 
• Agree to the notification page. 
• Click Next. 
• Deselect the Perform backup option. 
• Click Next. 
• Select the Most_Recent folder from the backup folder just copied. 
• Click Next. 
• Continue through the procedure to restore the most recent copy of the office’s data to 

the new server. 
18. Set the workstations to look to the new server. 
• Remap the network drive for OrthoTrac to the parent folder of the OMS folder on the 

server. 
• Verify all references to the old server are renamed in c:\windows\OMS.ini. 
• Select Options in c:\windows\system32\pwclient.exe (syswow64 for 64-bit 

installations). 
• Verify the path is set to the new server. 
• Run c:\oms\pwisetloc.exe. 
• Verify the proper data locations are selected. 
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Migrating an Existing Version 10 to a Version 11 or Higher Server 
We recommended that you work with support before migrating to a new server. OrthoTrac 
versions previous to version 10 must be updated incrementally. However, version 10 and later 
can be directly updated to the most recent version. Version 10 of OrthoTrac and previous 
releases did not run on modern Windows operating system releases, so support will have to 
manually update the datasets on the new server. The steps will be the same as the previous 
section; however, step 17 will require support assistance to update the MDB files from the old 
server’s OMS folder to version 11 or higher data. 
Note: Since the process is a transition between two different data structures, it may take several 
hours. 

New Workstation Installations 
Prior to installing OrthoTrac on a workstation, log in as a user with the correct administrative 
access to the server machine, and confirm the machine has a logical drive U:\ mapped to the 
appropriate share containing the OMS and OMS-Spec directories on the server. Do not map the 
U:\ drive directly to the OMS folder. It will prevent the workstation from updating correctly. If a 
drive other than U:\ is used, adjustments to the OMS.ini file located in C:\Windows must be 
made, as by default the workstation installation of OrthoTrac creates an OMS.ini file that 
expects the use of the U:\ drive designation. 
Notes: 

• The OrthoTrac support center expects the mapped drive to be U:\ and using anything 
other than U:\ could increase the amount of troubleshooting and time spent working on 
any issues. 

• In all installations, the DataPath= line in the [Awps] section of the OMS.ini file should 
always point to the local installation of OrthoTrac. For example: DataPath=C:\OMS 

Installation Across the Network 
OrthoTrac can also be installed across the network. The advantage of installing OrthoTrac 
across the network is it will automatically set the locations in the OMS.ini. 
This solution assumes the server is named Server and you are installing OrthoTrac on a 
workstation that is already connected to the network with proper permissions to access the 
server. This solution also assumes OrthoTrac is installed to the c: local disk drive on the server 
and that the c: drive on the server is mapped as the U: drive on the workstation. When installing 
on a system where these assumptions are incorrect changes must be made. 

1. From the Windows desktop, click Start > Run. 
2. Type U:\OMS-SPEC\Workstation Setup. 
3. Click OK. 
4. Double-click wsetup.exe. When the installation is complete, the system prompts for a 

reboot. 
5. After the computer has rebooted, log into OrthoTrac to confirm the installation was 

successful. 
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New Terminal Server Installation/Citrix Environments 
Installation to a Terminal Server or Citrix environment is similar to a regular workstation 
installation. However, the Terminal Server MUST be in install mode, and must be installed from 
the administrator’s console session. Windows install mode can be set simply by using the 
command change user /install, making sure once the installation is complete to return to 
change user /execute. An OMS.ini file is placed in each user’s %userprofile%\windows 
folder instead of the local C:\Windows folder. See the Microsoft Word in a Terminal 
Server/Citrix Environment section for details on setting up the office to print letters in a 
Terminal Services environment if the office will be printing letters directly from their Terminal 
Server. 

Licensing and Registration 
Before removing any software from the old server, copy the contents of the PWSVR folder 
which contains the license file. 
Notes: 

• This PWSVR folder is normally installed within the OrthoTrac folder on the data server. 
This location may vary if the office is using Carestream Dental Orthodontic Imaging. 

• Install the license file on the new server before installing the software on the 
workstations. 

• If you do not have a current copy of the license file, contact support. The support team 
can either send a copy via email or connect to the server and upload a copy. 

Installing the License File 
When a prompt to install the license file is displayed while installing or opening OrthoTrac, do 
the following: 

1. Browse to the location of the saved PWSVR file. 
2. Select the file. 
3. Click OK. 

Registering the Software 
When a prompt to register the software is displayed while installing or opening OrthoTrac, 
register the software using one of the following methods: 

• Register online via the internet 
• Contact support by phone 

Note: If you are unable to register the software at this time, click Cancel to continue with the 
update. You have seven days to register the product. 

To Register via the Intenet 
1. Select Automatically via the Internet. 
2. Click OK. The Registration Code window is displayed while the code is generated. 

After the registration code is obtained, the Installation Complete window is displayed. 
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3. Click Finish. 
Note: If you have registered the software more than three times, you will be required to contact 
support to receive a registration code. 

To Register by Phone 
1. Select Contact support by telephone. 
2. Click OK. 
3. Contact support using one of the following methods: 

• Call 866.722.2567. 
• Email orthotracsupport@csdental.com. 

4. Provide the Customer ID and Hardware ID information from the Registration window 
when contacting support. These numbers are used to generate the Registration Code. 

5. Type the registration code in the Registration Code field. 
Note: Use capital letters when typing the registration code. 

6. Click OK. The Installation Complete window is displayed. 
7. Click Finish. 

Backup Recommendations 
This section covers recommendations for configuring a backup routine for OrthoTrac data and 
related files. When setting up the backup routine, review the following sections in the OrthoTrac 
Configuration Guide in the Resource Library for more information. 

• Backing Up Data 
• Using a Backup Checklist 
• Establishing a Backup Routine 
• Managing Files and Backup Media 

Note: If the data was installed in a location other than the default directory, configure the 
backup system to back up the actual data location. 

Backing Up the Server 
IMPORTANT: It is the client’s responsibility to make sure they have a current backup of 
the OrthoTrac data. 
We recommend making a backup during lunch and at the end of each working day. 

The recommended methods for backing up data include online backup services and tape 
backup. 
Note: Flash drives and CD-RWs have been found to be inconsistent in testing due to 
degradation. Whichever backup solution is used, it is best to ensure the media is removed from 
the office at the end of the day or kept in a fireproof safe. 
Prior to running the system backup, the user should go to File > Prepare Backup from the main 
menu of OrthoTrac. This process creates .bak files of the OrthoTrac databases in the 
\OMS\Backup\Most_Recent folder. These files can be used to easily restore OrthoTrac data. 

mailto:orthotracsupport@csdental.com
https://gosensei.com/pages/resource-library


 

 
Page 10 

OrthoTrac Tech Pack 

OR600-02 

Keep in mind these files are not the only ones that should be backed up and because this 
‘backup’ is on the same hard drive as the original file, it is not a ‘true’ backup. The Prepare 
Backup process can also be automated by scheduling Windows to run the file 
OMS\Orthobac.exe. Because SQL runs using .MDF and .LDF files to store the physical data 
and SQL may hold these files with a system lock sometimes preventing backup, we recommend 
skipping these files in the daily system backup and ensuring the \OMS\Backup folder, instead, 
is copied in the actual backup process. 
If a scheduled backup is used, be sure to schedule the Prepare Backup feature, or schedule 
the Orthobac.exe process, prior to the actual file backup. We also recommend reading over the 
backup log each morning to ensure consistency. 

Tape Backups and Backup Frequency 
When using a tape backup, keep the following in mind: 
Keep two lunch backup tapes, one tape for each working day and two weekly tapes. For 
example, if the office is open Monday through Thursday, you would have two lunch backups 
that are used every other day, four daily backups and two weekly backups that would be used 
every other week. 
We also recommend you do an end of month backup. It is a good idea to keep two end of 
month backups at all times. For example, at the end of January, you should have a January end 
of month backup as well as a December end of month backup. 
Because backup media can malfunction or go bad, it is also a good idea to keep a spare backup 
tape in the event that one of the daily, weekly, or end of month backup tapes are unusable. 
We recommend taking physical backup devices off site when the office closes for the night in 
case of fires, flood, or other possibilities of system damage. 
Be sure the client is trained to configure and use their backup system. 

Recommended Files to Back Up 
Minimum recommended lunch backup files are: 

• C:\OMS\Backup\Most_Recent\*.* 
Minimum recommended daily backup files and folders are: 

• C:\OMS\Backup\Most_Recent\*.* 
• C:\OMS\Fingerprint.mdb 
• C:\OMS\Daysheet 
• C:\OMS\Docs 
• C:\OMS\Snapshot 
• C:\OMS\Toothcht 
• C:\OMS\ECS 
• C:\OMS\ICCPS 
• C:\OMS\ACH 

Minimum recommended weekly backup folders are: 
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• OMS folder location, generally: C:\OMS 
Minimum recommended monthly backup folders are: 

• C:\OMS 
• C:\OMS-Spec 

Note: These recommendations do not include backup information for Carestream Dental 
Orthodontic Imaging. 

Updating 
Before updating OrthoTrac, you should back up the server. For more information, see the 
Backing Up the Server section of this document. 
Most updates to OrthoTrac are quite simple. The install media should be inserted in the data 
server machine, which will take the user through the install process. After the data server is 
updated, OrthoTrac should be launched on all local workstations and the console session of the 
Terminal Server in install mode (when applicable). 

Server Updates 
To update the server, download the installation files from the digital download website and 
mount the ISO on the server. 
Note: OSetup.exe should always be run on the server. The update always begins by searching 
the local hard drive for installations of OrthoTrac. 
If the server has a large hard drive, this search can take a while to complete. You can bypass 
the search for an existing installation by launching the WSetup.exe program with the 
/PATH=<installdirectory> switch. 
Note: The switch is case-sensitive and must be all uppercase. For example: D:\WSetup.exe 
/PATH=C:\OMS 

Workstation Updates 
Typically, updating the workstations only requires starting OrthoTrac after the server has been 
updated. If the installation does not begin upon launching OrthoTrac, it can be executed 
manually by running the file U:\oms-spec\workstation setup\WSetup.exe. 

Upgrading Existing Terminal Servers/Citrix Environments 
We recommend disconnecting all users currently logged into the Terminal Server before 
updating OrthoTrac, since the software will not install properly if users are logged into OrthoTrac 
or any portion of the system. Set the console session of the Terminal Server to install mode by 
typing change user /install from a command prompt. Once this is done, launch OrthoTrac from 
the console session, and follow the prompts. If the installation does not begin upon launching 
OrthoTrac, it can be executed manually by running the file U:\oms-spec\workstation 
setup\WSetup.exe. 
Note: After the update is complete, the Terminal Server must be set back to execute mode by 
running change user /execute.  
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Permissions and Settings 
Setting up the Server 
Extra steps may be required as far as configuration of the server. This section includes 
configuration for automatically logging into the server and backing up the server. 

Automatic Login 
OrthoTrac requires the server be logged into the desktop for OrthoTrac to function on the 
workstations, even if OrthoTrac is not going to be used on the server. OrthoTrac licensing runs 
as an application on the console session of the server. While the session can be locked, it 
should never be completely logged out. 

1. Double-click the gold key in the Windows system tray on the server. 
2. Click Options. 
3. Click Automatic Server Logon Configuration. 
4. Type the user name in the User Name field. 
5. Type the password in the Password field. 
6. Click OK to save the changes. 
7. Click OK to close the PracticeWorks Server window. 
8. Verify the computer now logs in automatically when the server is turned on. 

If control over this functionality of your system by OrthoTrac support is not desirable, it may be 
best to contact Microsoft support to find the best alternative to having an administrator 
automatically log into the console session of the server. 

Non-Admin Settings 
OrthoTrac is optimized to run under an operating system user account with administrative 
privileges, as a member of the Administrators group. To run the software without making the 
user account a member of the Administrators group, some changes must be made to the 
restricted user’s permissions. Some additional changes must be made to run specific features. 
This document describes these changes. Generally speaking, where appropriate, these 
changes should include read, write, and modify permissions. 

Global Permissions 
HKEY_LOCAL_MACHINE\Software\PWInc 
Permission to INI files: OMS.ini, etc. 
Permission should be granted to all INI files used by the application, including particularly the 
OMS.ini. This is a concern when the INI file is stored in the Windows folder, typical for 
standalone workstations. Under a Terminal Services environment, the INI is stored in the user 
profile, and this is usually not a concern. 

Server Permissions 
HKEY_Local_Machine\Software\Microsoft\Windows\CurrentVersion\Run 
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Workstation Permissions 
Workstations require full read, write and modify access to the OMS and OMS-SPEC folder and 
all of its files and subfolders housed on the server, and to the c:\oms folder (regardless of install 
settings). 

Access to System Time 
Limited users cannot change the system time. OrthoTrac requires that computers are set to the 
correct time to ensure certain time-dependent features, such as the Scheduling and Patient 
Flow modules, work correctly. Administrators will have to ensure the time is correct in these 
cases. However, this is a case where limiting user access may be worth considering, as if the 
user accidentally sets an incorrect system time, this can have adverse effects on the Patient 
Flow and Charting modules. 

Features Requiring Registry Edits 
Several features require access to different registry keys and locations. 

Electronic Services 
If a user is using eServices, the user must be a full administrator on the machine. 
HIPAA Auto-Logoff: 

• HKCU\System\Microsoft\Windows\CurrentVersion\Policies\System 

Carestream Dental Orthodontic Imaging 
Carestream Dental Orthodontic Imaging (CSOI) recommends users to be given full 
administrative privileges as this listing may not cover the full range, as multiple devices and 
alterations to unique imaging installs may cause further registry entries to be required. The 
IMAGE folder on the server will need full rights. Additionally, the following keys are required, 
though there may be more.  
Note: The keys may be under wow6432node where appropriate. 

• HKLM\Software\Practiceworks\Image 
• HKCU\Software\Practiceworks\Image 

Third Party Products 
OrthoTrac integrates with multiple third-party vendors. Some additional configuration for clients 
that use these products may be required. 
Note: This listing is not a complete list of third-party integrated products used by the office. It is 
used to aid with the most common issues. For a more comprehensive list of third-party products 
integrated with the software, refer to the System Requirements. 

Microsoft Word 
IMPORTANT: OrthoTrac does NOT work with any Office, Home, Student or any web-based 
versions of Word (Office 365).  
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We only support Microsoft Word Professional versions for printing letters for the office. For 
acceptable Word versions for your current version of OrthoTrac, see the System 
Requirements. Because OrthoTrac uses extensive macros in these processes, make sure 
macros are allowed in the Word installation. 

Microsoft Word in a Terminal Server or Citrix Environment 
OrthoTrac makes extensive use of macros when printing Word documents. These documents 
access files that must be unique to each user. In Terminal Service and Citrix environments, 
multiple users are simultaneously accessing the same word processing resources, so these 
environments require a unique database setup for use with Microsoft Word. By default, we use 
W:\. Though the drive location can be changed, we recommend continuing to go with defined 
standards for ease of troubleshooting. The drive location must be seen as a local drive on boot; 
a network drive will not suffice. This guide will also cover the use of the AWPSUTILITY.EXE 
which can automate several parts of this process. This utility is included in versions 12 or higher 
of OrthoTrac. It can be found in the \OMS-Spec\Utility folder on the server. Local word 
processing configuration is performed when launching the program. More in-depth commands 
can be found if needed, but require a code of the day, which can be generated by OrthoTrac 
support if needed. 

Definitions for Microsoft Word in a Terminal Server/Citrix Environment 
Terminal Server – All references in this section to Terminal Server are referring to the server 
the users log in to remotely access their OrthoTrac system. 
Data Server – Data server refers to where OrthoTrac stores Microsoft Word documents, and 
does not necessarily mean where the other data is stored. The data server and the Terminal 
Server may or may not be the same machine. 
Data Files – The following files are used by OrthoTrac to export data from the database and to 
use Word as an intermediary: 

• Envelope.txt 
• Envelope.hdr 
• Omsawps.txt 
• Omsawps.hdr 

Each user must have explicit, unique access to these files, because two users writing to the 
same files at the same time will cause a data mismatch. The files, by default, are stored in the 
OMS folder but for offices using Terminal Services, the files will be stored in a TEMP folder. 

Changes to Be Made on a Data Server 
IMPORTANT: We strongly recommend making a backup of the OMS\DOCS folder BEFORE 
following these instructions. 
We will need to change ALL documents to have W:\TEMP be the primary data location. Macro 
settings in each individual .doc file pulls data from the Word data files. 
The first step towards this change is to modify the OMS.ini on the server. If the server is a 
Terminal Server/Data Server combo, the OMS.ini will be located in 
%userprofile%\windows\OMS.ini for the user currently logged in. Otherwise, it will be located 
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in c:\windows\OMS.ini. In the [AWPS] section of the OMS.ini, verify the following lines: 
datapath=w:\temp and datasource=server. 
The program AWPSUTILITY.EXE can be used to set the data source automatically as long as 
the OMS.ini for the user logged in is set correctly. When launching the utility, you can select an 
individual file, and click Repair Selected Doc(s). You can also Repair All Documents using 
the Support Login and a code of the day, which can be generated by OrthoTrac support if 
needed. 

Changes to Be Made on the Terminal Server 
The file rootdrv2.cmd should be installed if OrthoTrac is installed on the Terminal Server using 
the installmode, but if it is not, it can be edited. This file can be edited using notepad. It should 
contain the following lines: 
Set RootDrive=W: 
Subst /d %RootDrive% >NUL: 2>&1 
Subst %RootDrive% "%userprofile%" 
Do not attempt to set up a W:\ with net use. If a drive other than W:\ is desired, it can be edited 
for use in rootdrv2.cmd. 
ALL USERS must have a Temp folder with all OMS WORD DATA FILES required located in 
their user profile. ALL USER OMS.ini files located in %userprofile%\windows\OMS.ini must 
have datapath=w:\temp and datasource=server set. Adding these changes to the default 
profile will also ensure the settings are applied to all new users when they are added to the 
system. NO TWO USERS SHOULD EVER BE ACCESSING THE SAME DATA PATH OR 
SESSION, OR ERRORS WILL BE ENCOUNTERED. 
Launching the utility AWPSUTILITY.EXE will attempt to automatically fix all users’ profiles with 
the above information 

Changes to Be Made on All Local Workstations 
Note: The following changes are necessary because even though the local PCs are not using 
WTS, they must still access the AWPS documents using the same path and data source that 
the WTS workstations use. 

1. Create drive C:\AWPSTEMP\TEMP. 
2. Copy all OMS WORD DATA FILES to this location. 
3. Create file wdrive.bat using notepad with the following information: 
• SUBST W: C:\AWPSTEMP 
4. Run the newly created .bat file. 
5. Place the .bat file in the user’s startup folder in their Windows start menu. 
6. Edit the OMS.ini located in c:\windows\OMS.ini. In the [AWPS] section, verify the 

following lines: datapath=w:\temp, and datasource=server. 
Note: Launching the utility AWPSUTILITY.EXE will attempt to automatically perform the above 
settings. 
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Antivirus 
If the client maintains a continuous connection to the internet, it is advised that antivirus 
software be installed. If antivirus software has been installed, it is suggested that both active 
scanning of macros and of .doc and .dot files be disabled, as such active intervention can 
disrupt the automation of letter printing using AWPS. We also recommend adding the OMS 
folder on both the workstation and the server, and the OMS-SPEC folder on the server to the 
exclusions list of your antivirus software. Even with these settings in place, support has noticed 
that several antivirus programs still find “false positives” and quarantine OrthoTrac files. While 
we cannot verify specific settings internally, several inconsistencies have been found with AVG. 

Firewall 
If a hardware or software firewall has been installed, it must not interfere with internal network 
traffic and should only filter traffic between the internal network and the network of the upstream 
internet provider. Additionally, appropriate port mapping may be required by configuring the 
firewall insofar as it is necessary to allow for support to connect using remote administration 
software as discussed in the System Requirements. 

Uninstalling OrthoTrac 
IMPORTANT: Make a backup (see Backing Up the Server) and remove any data BEFORE 
following these instructions. 
OrthoTrac does not come with uninstall media. As such, uninstalling the program involves 
several steps, including editing the registry. If you are not comfortable with this process, call 
OrthoTrac support so that a representative can aid in this process. 

Uninstalling OrthoTrac on a Server 
1. Remove the OMS folder, generally C:\OMS. 
2. Remove the OMS-Spec folder, generally C:\OMS-Spec. 
3. Uninstall SQL. 
• This can be done through the Add/Remove Programs section of the Control Panel. 

You will be given options for removing SQL. 
• Be sure to uninstall the instance of ORSQLEXP. 
4. Several registry entries must be removed. Within regedit, remove keys from the 

following locations: 
• HKCU\SOFTWARE\ORTHOTRAC 
• HKCU\SOFTWARE\PRACTICEWORKS\ORTHOTRAC 
• HKCU\SOFTWARE\PWINC\ORTHOTRAC 
• HKEY_USERS\S-1-5-21-*\Software\OrthoTrac 
• HKEY_USERS\S-1-5-21-*\Software\PracticeWorks\OrthoTrac 
5. Remove the file C:\WINDOWS\OMS.ini. 
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Uninstalling OrthoTrac on a Workstation 
1. Remove the C:\OMS folder. 
2. Several registry entries need to be removed. Within regedit, remove keys from the 

following locations: 
• HKCU\SOFTWARE\ORTHOTRAC 
• HKCU\SOFTWARE\PRACTICEWORKS\ORTHOTRAC 
• HKCU\SOFTWARE\PWINC\ORTHOTRAC 
• HKEY_USERS\S-1-5-21-*\Software\OrthoTrac 
• HKEY_USERS\S-1-5-21-*\Software\PracticeWorks\OrthoTrac 
3. Remove the C:\WINDOWS\OMS.ini file. 

Frequently Asked Questions 
Q: Can I run OrthoTrac on Windows 8.1 and 10/Mac/Linux/Unix/OS2 or some other 
operating system not listed in the system requirements? 
A: We only list the operating systems we have tested with OrthoTrac. OrthoTrac only runs in 
Microsoft Windows. We have tested on a Mac using a VM or dual boot, but not any other type of 
Windows emulator. In the past, we have not completed our testing of OrthoTrac on new 
Windows operating systems until the release of the first service pack for the operating system. 
Q: Will OrthoTrac work running in a virtual server? 
A: While OrthoTrac will work running in a virtual environment, we have not tested in this 
environment, and we have encountered multiple clients who have run into severe data 
connectivity issues when running in a virtual environment. Finally, we have experienced several 
issues involving updating virtual environments. As such, OrthoTrac support’s official policy is 
that virtual environments are unsupported. We would strongly recommend against using a 
virtual environment, and we cannot guarantee we will be able to assist if problems are 
encountered in a virtual environment. 
Q: What about Small Business Servers? 
A: OrthoTrac will not work properly on a Small Business Server. 
Q: What happens if I use hardware or software that support tells me is not supported? 
A: OrthoTrac support will attempt to remedy situations that may arise from using non-supported 
hardware and software; however, in situations where we cannot find a way to resolve the issue 
with the technology the client is using, we may recommend using supported systems to resolve 
the issue. In all cases where data is involved, we will work with the client to the best of our 
ability to ensure the stability and reliability of their data regardless of technology used. 
Q: Can I get the user name and password for SQL? 
A: The data belongs to the client, and we will always work with the office to ensure access to 
their data; however, the structure of data is proprietary to Carestream Dental. As well, in cases 
where access to the office’s data is given, we cannot verify in a court of law that the client’s data 
has not been tampered in cases where an office’s data is called into question. As such, we do 
not provide access to the database, as a precaution to the office. 
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Q: Can I run the license server as a service? 
A: We have seen multiple offices who have found a way to encapsulate the license as a service; 
however, as we have done no testing in-house on this, we cannot support this setup, and will 
recommend changes to the office to run the license as a regular application on launch. 
Q: Can I use a wireless network? 
A: OrthoTrac requires stable and expedient networking. Multiple errors can occur without a 
consistent data throughput, not limited to but including SQL disconnects, and load flow array 
errors that may disrupt the office’s work flow. As such, we do not recommend wireless networks 
for mission critical stations. 

Related Documentation and Resources 
Additional information available in the Resource Library (gosensei.com): 

• Initial Training Workbook 
• Online Help 
• Release Notes 
• Link to our virtual agent, Cassidy 

o gosensei.com/pages/orthotrac-support 
Cassidy is Carestream Dental’s AI-powered virtual agent offering 24/7/365 online 
customer support. When you need a quick step-by-step guide or question on product 
needs, information is instantly available via Cassidy. 

• Link to the Carestream Dental Institute: carestreamdental.com/cdi 

Troubleshooting Steps for Common Installation and Update 
Issues 
MSVCRT.DLL COULD NOT BE OPENED 
Note: This solution should only be used when installing ON A SERVER in a DOMAIN 
ENVIRONMENT. 
Issue: When installing OrthoTrac in a domain environment the following error is presented: 
Error – MSVCRT.DLL Could Not Be Opened 

Cause: Incorrect User/Group Permissions 
Solution: 

1. The local tech must create a local user with administrative privileges or disable the group 
policy and begin the install again. 

2. It may also be necessary to change the ownership and permission on the 
MSVCRT.dll. The file is in C:\Windows\SysWow64. 

o If it is a domain controller the local technician must change ownership of 
the MSVCRT.dll from TrustedInstaller to the Administrators group and give the 
Administrators full control. 

https://gosensei.com/pages/resource-library
https://gosensei.com/pages/orthotrac-support
http://carestreamdental.com/cdi
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o Other DLL files may fail after that change. The local tech must also change 
Administrators control over those files. 

 
CAN'T CONTINUE – MUST BE IN APP SERVER MODE 
Issue: When attempting to install or update OrthoTrac on a terminal server, the following error 
message is received: 
Can't continue because this computer is in a mode (Terminal Server Client) which is 
incorrect! Instead, it must be running in Application Server Mode. 

Cause: Terminal Server is not in Install Mode. Installing OrthoTrac on a Terminal Server 
requires a direct console session to the server and requires the server be in Install Mode. 
Solution: Change the Terminal Server from Execute Mode to Install Mode. 

1. Click Start > Run. 
2. Type cmd. 
3. Press Enter. 
4. Type change user /install. 
5. Press Enter. A prompt is displayed stating the Terminal Server is now in Install Mode. 
6. Run the OrthoTrac install process again. 

Note: After the install process completes, the Terminal Server must be set back to Execute 
Mode. 

1. Click Start > Run. 
2. Type cmd. 
3. Press Enter. 
4. Type change user /execute. 
5. Press Enter. A prompt is displayed stating the Terminal Server is now in Execute Mode. 

 
WINDOWS INSTALLER ERROR: PREPARING TO INSTALL POP-UP IN VARIOUS 
FUNCTIONS 
Issue: A Windows Installer message is displayed when accessing various OrthoTrac 
functions. 
Cause: Possibly related to Windows permissions or Windows updates. 
Solution: 

1. Check for recent Windows updates. If there are updates that need to be downloaded or 
installed, download and install all of them. 

2. If the issue is not resolved, exit OrthoTrac. 
3. Right click the OrthoTrac shortcut and select Run as administrator. 

o If the issue is resolved, the local technician will need to ensure the user is set up 
as an administrator. 
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TERMINAL SERVICES ERROR: INSTALL MODE DOESN'T APPLY TO RDP SESSION 
Issue: When attempting to run the command change user /install to set a Terminal Server to 
Install Mode to install or update OrthoTrac, the following message is displayed: 
Install mode doesn't apply to a Remote Desktop Session Host server configured for remote 
administration. 
Cause: This indicates you are trying to run the OrthoTrac install from a remotely connected 
RDP session instead of a direct console session. 
Solution: Installing OrthoTrac on a terminal server requires the server be in Install Mode. It will 
be necessary to obtain a direct console session to the Terminal Server itself. 

1. Use a direct console session to the Terminal Server. 
2. Turn off Remote Administration services. 
3. Disconnect all remote users. 
4. Proceed with the install. 

 
MORE THAN ONE INSTALLATION OF ORTHOTRAC WAS FOUND 
Issue: When running an update for OrthoTrac, the following message is displayed: 
More than one installation of OrthoTrac was found. 
Cause: This issue is frequently the result of someone making a backup copy of the \OMS folder 
prior to running the update. The backup copy of the folder is on a local disk drive. When the 
update is started it scans all local drives to see where OrthoTrac is installed. Specifically, it is 
looking for the Orthooff.exe file. If more than one copy of Orthooff.exe is found the update 
stops and the message is displayed. 
Solution: 

1. Open OrthoTrac on the computer where the error message is displayed. 
2. From the main menu of OrthoTrac, click Options > Environment. 
3. Make a note of the information in the Server Path field. 

Note: The information in step 3 is the active directory that should contain the 
Orthooff.exe. All other copies of the Orthooff.exe should be renamed or removed from 
the local hard drive. 

4. Click OK. 
5. Close OrthoTrac. 
6. From the Windows Start menu, click Start > Search. 
7. Select For Files and Folders. 
8. Click All files and folders. 
9. Type Orthooff.exe. 
10. Click Search. 
11. When the search results are displayed, rename or delete all copies of Orthooff.exe, 

except the one in the path noted in step 3. 
Note: To display the file paths for the files, click View > Details from the main menu bar. 
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Note: If there are no results for the file search except the active directory found in step 3, there 
may be issues with file indexing being disabled for Windows Search. In these cases, obtain the 
location of the extra copies of the Orthooff.exe by checking the installation log found at 
C:\Windows\oms1100setup.log. 

12. Close the Windows Explorer Search window. 
13. Run the update again. 
14. Verify the update installs without the error message. 

 
SEARCHING FOR INSTALLED COMPONENTS – DATA SERVER 
Issue: The update hangs at the Searching for Installed Components phase of the installation. 
Cause: If OrthoTrac is installed in a complex folder path or if the Data Server has many external 
drives, the update may take a long time to find the installed component path and will appear to 
be non-responsive. 
Solution: Bypass the automatic search for Installed Components phase of the update by 
specifying the install path as part of the Run command. 
Note: All users must be out of OrthoTrac. 

1. Browse to the location of the OrthoTrac update files and note the drive. 
o In the following example the drive is D:\. 

2. Click Start > Run on the Data Server. 
3. Type the following: "D:\Osetup.exe" /PATH=C:\OMS. 

o Quotations marks must be used around the Osetup.exe path. 

Note: The C:\OMS in the command represents a standard installation. Depending on the actual 
installation the command may have to be modified. If you are not certain of how to modify the 
command correctly, please seek assistance. The /PATH=C:\OMS must be in caps. 
WARNING! Do NOT run this command on a workstation. There is a separate instruction 
for workstations. 

4. Click OK. The Installation Wizard is displayed. 
5. Follow the prompts to install the OrthoTrac update as a Server instance. 

 
SEARCHING FOR INSTALLED COMPONENTS – WORKSTATIONS 
Issue: The update hangs at the Searching for Installed Components phase of the installation. 
Cause: If OrthoTrac is installed in a complex folder path or if the Data Server has many external 
drives, the update may take a long time to find the installed component path and will appear to 
be non-responsive. 
Solution: Bypass the automatic search for the Installed Components phase of the update by 
specifying the install path as part of the Run command. 

1. Click Start > Run on the workstation. 
2. Type the following: "U:\OMS-SPEC\Workstation Setup\Wsetup.exe" /PATH= C:\OMS. 

o Quotations marks must be used around the Wsetup.exe path. 
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Notes: The paths in the command represent a standard installation. Depending on the actual 
installation the command may have to be modified. If you are not certain of how to modify the 
command correctly, please seek assistance. The /PATH=C:\OMS must be in caps. 
WARNING! Do NOT run this command on the Data Server. There is a separate instruction 
for the Data Server. 

3. Click OK. The Installation Wizard is displayed. 
4. Follow prompts to install the OrthoTrac update as a Workstation instance. 

 
Update Hangs at the Searching for Installed Components Phase of the Installation 
Cause: If OrthoTrac is installed in a complex folder path or if the Data Server has many external 
drives, the update make take a long time to find the installed component path and will appear to 
be non-responsive. 
Solution: Bypass the automatic search for the Installed Components phase of the Update by 
specifying the install path as part of the Run command. 
Note: All users must be out of OrthoTrac. 

1. Browse to the location of the OrthoTrac update files and note the drive. 
o In the following example the drive is D:\. 

2. Click Start > Run on the Data Server. 
3. Type the following: "D:\Osetup.exe" /PATH=C:\OMS. 

o Quotations marks must be used around the Osetup.exe path. 

Notes: The C:\OMS in the command represents a standard installation. Depending on the 
actual installation the command may have to be modified. If you are not certain of how to modify 
the command correctly, please seek assistance. The /PATH=C:\OMS must be in caps. 
WARNING! Do NOT run this command on a Workstation. There is a separate instruction 
for workstations. 

4. Click OK. The Installation Wizard is displayed. 
5. Follow prompts to install the OrthoTrac update as a Server instance. 

 
WTS – ORTHOTRAC SOFTWARE IS IN USE 
Issue: A message stating OrthoTrac software is in use on another workstation is displayed, 
while attempting to run the update on the terminal server. PWClient and Terminal Manager both 
show no users logged in. 
Cause: The Terminal Server is not in Install Mode. 
Solution: Change the Terminal Server from Execute Mode to Install Mode. 

1. Click Start > Run. 
2. Type cmd. 
3. Press Enter. 
4. Type change user /install. 
5. Press Enter. A prompt is displayed stating the Terminal Server is now in Install Mode. 



 

 
Page 23 

OrthoTrac Tech Pack 

OR600-02 

6. Run the OrthoTrac install or update process again. 
Note: After the install process completes, the Terminal Server must be set back to Execute 
Mode. 

1. Click Start > Run. 
2. Type cmd. 
3. Press Enter. 
4. Type change user /execute. 
5. Press Enter. A prompt is displayed stating the Terminal Server is now in Execute 

Mode. 
 
CANNOT ESTABLISH A VALID CONNECTION TO… WHEN STARTING ORTHOTRAC ON 
ALL MACHINES INCLUDING SERVER 
Issue: When starting OrthoTrac the following error is displayed: 
This computer cannot establish a valid connection to: 
Database: OMS 
DataSet: Main 
SQL Server Name: 

Or 
This computer cannot establish a valid connection to: 
Database: OMS (Error-[DBNETLIB][ConnectionOpen(Connect()).]SQL Server does not exist or 
access denied.) 
DataSet: Main 
SQL Server Name: 

Cause: Multiple causes, see below. 

Solution: Verify PWSvr is running on the data server. If it is not running, start it or if it is already 
running, stop and restart it. 

1. Look for the gold PWSvr key in the system tray on the server. 
o If the key is not visible, skip to step 3. 
o If the key is present, proceed to the next step. 

2. Right-click the gold key and select Exit PracticeWorks Server. 
3. Browse to the folder where OrthoTrac is installed. 
4. This is usually C:\OMS but may vary depending on the installation. 
5. Double-click the PWSvr folder. 
6. Double-click the PWSvr.exe file to restart the PWSvr process. 
7. Try to launch OrthoTrac on the server. 

o If it launches, the problem is resolved. Try the workstations as well. 
 
Check the Status of the SQL Service 

1. From the Windows taskbar, click Start > Run. 
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2. Type services.msc. 
3. Click the Standard tab on the right-side. 

o This tab is displayed at the bottom of the right-side. 
4. Locate SQL Server (ORSQLEXP). 

o If the SQL Server (ORSQLEXP) does not show as Started, right-click on it and 
select Start. 

o If the SQL Server (ORSQLEXP) already shows as Started, right-click on it and 
select Restart. 

o If the SQL Server (ORSQLEXP) does not show as Startup Type of Automatic, 
right-click on it and select Properties. Select Automatic from the Startup 
Type drop-down list. Click Apply and OK. 

 
Verify Settings for SQL Server 
Use the SQL Server Configuration Manager to set the start mode for SQL Server to 
Automatic and verify the network / protocols configuration is correct. 

1. On the data server, click Start > Microsoft SQL Server 2014 > Configuration Tools > 
SQL Server Configuration Manager. 

2. Right-click the SQL Server (ORSQLEXP) in the right pane, then click Properties. 
Note: The SQL server version may vary, look for the version of SQL you have installed. If 
the SQL Server (ORSQLEXP) is not showing in the right pane of the window, click 
on SQL Server Services in the left pane of the window. 

3. Select the Service tab. 
4. Select Automatic from the drop-down list to the right of Start Mode. 
5. Click Apply. 
6. Click OK. 

Note: If the SQL Server (ORSQLEXP) shows as Stopped, right-click on it, and select Start. 
7. Repeat steps 02 through 06 for the SQL Server Browser lines. 
8. Click on the plus sign next to SQL Server 2014 Network Configuration in the left pane of 

the SQL Server Configuration Manager window to expand the choices. 
9. Click on Protocols for ORSQLEXP. The Protocols (Pipes) will be displayed in the right 

window. The Shared Memory, Named Pipes, and TCP/IP protocols must be set 
to Enabled. 

10. Right-click on any of the disabled protocols and click Enable. A warning is displayed 
stating the following: WARNING! Any changes made will be saved; however, they will 
not take effect until the service is stopped and restarted. 

11. Click OK to acknowledge the warning. 
12. Repeat steps 10 and 11 for other protocols that should be enabled. 
13. Close the SQL Server Configuration Manager. 
14. From the Windows taskbar, click Start > Run. 
15. Type services.msc. 
16. Click the Standard tab on the right side. 
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o This tab is displayed at the bottom of the right-side. 
17. Locate SQL Server (ORSQLEXP). 
18. Right-click on SQL Server (ORSQLEXP) and select Restart. 
19. Locate the SQL Server Browser in the right pane of the Computer Management window. 

It will be a few lines below SQL Server (ORSQLEXP). The SQL Server 
(ORSQLEXP) should be set to Started in the Description column. 

20. If the SQL Server (ORSQLEXP) is stopped, right-click on it and click on Restart. 
 
ERROR – CANNOT ESTABLISH A VALID CONNECTION TO… WHEN STARTING 
ORTHOTRAC ON SOME WORKSTATIONS OR TERMINAL SERVER USERS 
Issue: When starting OrthoTrac the following error is displayed. 

This computer cannot establish a valid connection to: 
Database: OMS 
DataSet: Main 
SQL Server Name: 

Or 

This computer cannot establish a valid connection to: 
Database: OMS (Error-[DBNETLIB][Connection Open(Connect()).]SQL Server does not exist or 
access denied.) 
DataSet: Main 
SQL Server Name: 

Cause: Multiple causes, see below. 
Solution: If the problem occurs on a workstation or terminal server user but not the server, 
check the OMS.ini settings. 
Note: If the issue is happening for just one or some WTS users, it indicates the oms.ini file in 
the profile associated with the specific terminal server user is missing the correct 
information. For terminal server user profiles, the oms.ini file resides under the user profile in a 
windows subfolder. For example: C:\users\[username]\windows\oms.ini 
Below are several lines in the OMS.ini that can cause the error if the incorrect information is 
present. 
ServerName= 
DbName= 
Usr= 
Pwd= 
The information can be copied from the OMS.ini of a working workstation. 

1. From the Windows taskbar on a workstation where OrthoTrac is running correctly, 
click Start > Run. 

2. Type oms.ini. 
3. Click OK. 
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4. Copy the lines for ServerName=, DbName=, Usr=, and Pwd= into a text file and move it 
to the workstation having the problem. 

o ServerName= should be followed by the name of the SQL server used to log into 
Microsoft SQL Server Management Studio Express, i.e. 
ServerName=KDS001234\ORSQLEXP. 

o DbName= in most installations will be Main, i.e. DbName=Main. 
o Usr= in most installations will be sa, i.e. Usr=sa. 
o Pwd= contains an encrypted version of the database password. 

Note: Because it is an ENCRYPTED version of the database password this should be copied 
from a working workstation and pasted into the OMS.ini. Manually typing the password, even if 
it looks exactly like the one from a working workstation, will usually not work. 

5. Close the oms.ini. 
6. From the Windows taskbar on the workstation with the error, click Start > Run. 
7. Type oms.ini. 
8. Click OK. 
9. Insert the information from the text file in step 04. 
10. Save and close the oms.ini. 

The problem may be caused by an anti-virus program stopping some necessary OrthoTrac 
.exe, .dll or .ocx files to function. Temporarily turn off any anti-virus software and attempt 
connecting again. If the connection can be established with the anti-virus software off, the office 
technician should set exclusions for the C:\oms and C:\oms-spec files and folders. 
If the problem occurs on a workstation but not the server, check the Hosts file at 
C:\WINDOWS\system32\drivers\etc\hosts file to make sure there are no extra lines in it. 

1. From the Windows taskbar on the workstation having the problem, click Start > Run. 
2. Type C:\windows\system32\drivers\etc\. 

o C:\Windows\SysWOW64\drivers\etc on 64-bit systems. 
3. Click OK. 
4. Open the Hosts file using Notepad. 
5. Confirm there is nothing in the file beyond the localhost line. If there is, remove it. 
6. Save and close the Hosts file. 
7. Open OrthoTrac. 

If the problem occurs on the workstation but not the Data Server, it may be due to DNS issues. 
1. From the Windows taskbar on a workstation having the problem, click Start > Run. 
2. Type cmd. 
3. Click OK. A DOS command window will open. 
4. Type Ping <servername>. 

Note: Replace <servername> with the server's name. This can be found in the OMS.ini. 
5. Press Enter. 

o If there is a normal response to the ping, make a note of the IP address of the 
server. 

6. From the Windows taskbar on the data server, click Start > Run. 
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7. Type cmd. 
8. Click OK. A DOS command window will open. 
9. Type ipconfig. 
10. Press Enter. 
11. Make a note of the IP address of the server. The IP Address should match the one noted 

in step 5. 
o If it does NOT, open the OMS.ini and replace the 

ServerName=ServerORSQLEXP line with 
ServerName=<IPADDRESS>ORSQLEXP. 

i. Replace <IPADDRESS> with the IP address from step 5. 
o This indicates a situation the local tech should resolve. Making this change in the 

OMS.ini will resolve the issue until the server is rebooted and possibly getting a 
new IP address. The local technician should be made aware the PING SERVER 
returned a different IP address on the workstation than it did on the server. 

12. From Windows taskbar on the workstation getting the error, click Start > Run. 
13. Type cmd. 
14. Click OK. A DOS command window will open. 
15. Type ping -a <IPADDRESS>. 

Note: Replace the <IPADDRESS> with the server's IP address. 
16. Press Enter. 

o If there is a response to the ping using the IP address but there was no response 
to the ping using the server's name, OR if the machine name returned in step 15 
is not the same as the server name in step 04, the problem is a DNS 
issue. Inform the local technician and make the following changes to the 
Servername= line of the OMS.ini file on the workstation having the problem. 

i. Change from: Servername=SERVER\ORSQLEXP 
ii. Change to: Servername=<IPADDRESS>\ORSQLEXP 

Note: Replace the <IPADDRESS> with the IP address from step 11. 
The SQL server browser (SQLBrowser.exe) may have stopped. Occasionally, after a windows 
update, the SQL server browser (SQLBrowser.exe) will be disabled. This can prevent access to 
the SQL database. Sometimes this will cause a problem on all computers, sometimes it will only 
be one workstation. 

1. Open the Task Manager on the data server. 
2. Select the Processes tab. 
3. Locate the SQLBrowser.exe. If it is listed among the other processes, try the other 

possible causes of the problem. If it is not listed, continue to the next step. 
Note: Clicking on the Image Name column header will put all of the processes in alphabetical 
order, making it easier to find the SQLBrowser.exe. 

1. Close the Task Manager. 
2. Right-click on My Computer and click on Manage. 
3. Double-click Services and Applications. 
4. Double-click Services. 
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5. Right-click on SQL Server Browser and click Properties. 
6. Set Startup Type to Automatic. 
7. Click the Start button under Service status to restart the service. 
8. Click OK to close the SQL Server Browser Properties. 
9. Close Computer Management. 
10. Open the SQL Server Configuration Manager by clicking Start > Programs > Microsoft 

SQL Server 2014 > Configuration Tools > SQL Server Configuration Manager. 
11. Select SQL Server 2014 Services. 
12. Right-click SQL Server Browser and select Restart. 
13. Right-click SQL Server (ORSQLEXP) and select Restart. 
14. Close the SQL Server Configuration Manager. 

If this problem occurs every other time OrthoTrac is started, un-check Compatibility mode in 
the OrthoTrac icon properties. 

15. Right click the OrthoTrac icon on the desktop then click Properties. 
16. Select the Compatibility tab. 
17. Remove the check mark from Run this program in compatibility mode for in 

the Compatibility mode section. 
18. Click Apply. 
19. Click OK. 

Note: Windows firewall – SQL requires ports 1433 and 1434 open in order to work. If the 
Windows firewall is installed when OrthoTrac is installed these ports will be opened during the 
installation. Otherwise, the local technician will have to open these ports. 
 
ERROR – ALL WORKSTATIONS: TIMEOUT ERROR OCCURRED WHILE CONNECTING 
Issue: When attempting to open OrthoTrac on any computer the following error is presented: 
A timeout error occurred while connecting to the server. Please verify the server is running. 

Cause: Multiple issues can cause this error. 
• A valid Administrator user has not logged into the server either manually or 

automatically. 
• The client is connected to the server remotely through Microsoft Remote Desktop (RDP). 
• The PWSvr.exe is not an active process on the License Server. 
• PWSvr.exe is an active process on multiple computers. This process should only be run 

on the License Server. 
• The Clientlist.dat file is corrupt. 
• PWLF.dat (license file) is corrupt or missing. 
• In rare cases, the registry files on the Data Server have been removed or corrupted and 

OrthoTrac would need to be reinstalled on the License/Data Server. 
Solution: The most common cause for this error is a valid Administrator user isn't logged into 
the server. A user must be logged into the server for the Pwsvr.exe to run. OrthoTrac has the 
capability to log an administrator onto the server then lock the server. This is very important for 
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practices with multiple locations. If the server is NOT configured to log in automatically it may be 
necessary to send someone to the main office if the server restarts for any reason. The steps 
below will turn on the automatic login. 
 
How to Set the Server to Automatically Login to Windows 

1. From the Server, double-click the gold key on the Windows taskbar. 
2. Click Options. 
3. Click Automatic Server Logon Configuration. 
4. Select the Automatic Server Logon option. 
5. Type Administrator in the User Name field. 
6. Type the Administrator Password in the Password field. 
7. Click OK. 
8. Click Close to close the PracticeWorks Server window. 
9. Restart the server to verify it logs into Windows automatically. 

If the steps above do not resolve the issue, then proceed to the following steps: 
1. Verify PWSvr.exe is currently running. Check for the gold key icon in the system tray of 

the license server. 
2. If it is not visible, check the Task Manager to see if PWSvr.exe is listed in 

the Processes tab. 
3. If it is listed, click End Process. 
4. If it is not listed, or if the process was manually ended in step 3, relaunch PWSvr.exe 

manually. Browse to the folder where the file is located on the Data Server (by default, 
C:OMSPWSvr) and double-click the PWSvr.exe file. 

5. If the gold key icon reappears and remains visible in the system tray, try opening 
OrthoTrac. The problem may be resolved. 

 
Checking Remote Desktop Connections 
Remote Desktop connections generally do not connect to a Console or ID0 session with the 
server, and the gold key Will Not start in this mode. This type of connection is generally referred 
to as Terminal Services. If using Windows Server 2008 a session of ID1 may be used. 
To check if a user is connected via RDP: 

1. Go to a cmd line prompt. 
2. Type query session. 
3. Press Enter. This will show if you are in an RDP session. 

If the issue still persists, there may be multiple PWSvr.exe processes running on various 
computers. It is important the process is only run on the License/Data Server. 

1. From each workstation, open Task Manager and search for the PWSvr.exe process. 
2. Click the End Process button to manually end the process on all workstations. 
3. Restart the workstations. 
4. Verify PWSvr.exe is not automatically restarting on the workstations. 
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If the issue still persists, perform the following steps on the License/Data Server: 
1. From the Windows Start menu, click Start > Search. 
2. Type PWClient.exe. 
3. Click OK. 
4. Click Options. 
5. Make note of the path shown in the PracticeWorks Server Path field. 
6. Click Cancel. 
7. Click Close. 
8. From the Windows Start menu, click Start > Search. 
9. Enter the path noted in step 5 and click OK. 
10. Double-click the msg folder. 
11. If there are files with a name starting with 000, they must be deleted. You must exit from 

the PWSVR application, before deleting the files. 
12. Right-click the gold key in the system tray. 
13. Click Exit PracticeWorks Server. 
14. Delete the files in the OMS\PWSVR\Msg folder that have a name starting with 000. 
15. Delete the Clientlist.dat file in the OMS\PWSVR folder. 
16. Double-click PWSvr.exe in the OMS\PWSVR folder to restart it. 

If this does not resolve the problem, the license file (PWLF.dat) may be corrupt and should be 
replaced by Carestream Dental Support. 
 

TIMEOUT ERROR OCCURRED WHILE CONNECTING TO SERVER – ONE WORKSTATION 
ONLY 
Issue: When starting OrthoTrac on one workstation the following error is displayed: 
A timeout error occurred while connecting to the server. Please verify the server is running. 

Cause: There are several different things that can cause timeout errors. The different solutions 
below are arranged in order from the easiest things to check to the more difficult. 
Solutions: 
Verify Automatic Server Detection is selected 
A user must be logged onto the server in order for the PWSVR.exe to load. PWSVR can be 
configured to automatically log a user onto the server when it reboots then lock the server. 

1. Double-click the gold key on the server's task bar. 
2. Click Options. 
3. Select Automatic Server Detection. When the Automatic Server Detection option is 

not selected, the workstations will not be able to automatically detect that PWSVR.exe is 
running on the server. 

4. Select File System Message Polling. 
5. Set the Message Check Frequency to 5 seconds. 
6. Click OK. 
7. Click Close. 



 

 
Page 31 

OrthoTrac Tech Pack 

OR600-02 

8. Verify OrthoTrac will open on the workstation. 
 
Checking Remote Desktop Connections 
Remote Desktop connections generally do not connect to a Console or ID0 session with the 
server, and the gold key Will Not start in this mode. This type of connection is generally referred 
to as Terminal Services. If using Windows Server 2008 a session of ID1 may be used. 
To check if a user is connected via RDP: 
Windows 7 / Windows Server 2008: 

1. Press Ctrl-Alt-Delete. 
2. Select Task Manager. 
3. Select the Users tab. If the Session for the logged in user displays RDP-TCP the user is 

logged in via RDP. 
Windows 10/ Windows Server 2012 R2: 

1. Go to a cmd prompt. 
2. Type query session. 
3. Press Enter. This will show if the user is logged in an RDP session. 

Verify the PracticeWorks Server Path, File System Message Timeout and Mailslot 
Message Timeout in PWClient.exe. 

1. From the Windows Start menu, click Start > Run. 
2. Type PwClient.exe. 
3. Click OK. 
4. Click Options. 
5. Type the path to the PWLF.dat license file on the server in the PracticeWorks Server 

Path field. From most workstations the default mapped path would be U:\oms\pwsvr. 
6. Set the File System Message Timeout to at least 15. 
7. Set the Mailslot Message Timeout to at least 4. 
8. Click OK. 
9. Click Close. 
10. Open OrthoTrac to verify the issue has been resolved. 

Note: If the issue still occurs, see the Verify the Workstation is able to Ping the Server by Name 
section of this document. Try changing the path in pwclient to the path used for the mapped 
drive U:\ but replace the servername in the share with the IP address. 
Verify the computer can access the OMS folder on the server 
IMPORTANT! The workstation must be on the same workgroup as the server when the 
office is not using a DHCP network. 

1. Double-click the This PC or My Computer icon on the Windows desktop. 
o The name of the function depends on the Microsoft operating system version 

installed on the machine. If the icons are not visible on the desktop, do the 
following to display the icons: 
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i. Right-click anywhere on the desktop. 
ii. Select View. 
iii. Select Show desktop icons. 

2. Double-click the C-drive on the Server. 
o Typically mapped to U:\. This server path can be confirmed in the OMS.ini on the 

workstation. 
3. Double-click the OMS folder to ensure the workstation can access the OMS folder. 
4. Verify OrthoTrac will open on the workstation. 

Note: If a message is displayed indicating the workstation does not have permission to access 
the server, or is prompting for a user name and password, the workstation does not have proper 
permissions to access the server. Change the permissions on the server so the user name, the 
workstation is currently using has Administrator permissions. 
 
Disable and Re-enable the Network Connection on the Workstation 

1. Go to Control Panel > Network and Sharing Center. 
2. Right-click the Local Area Connection link. 
3. Click Disable. 
4. When the Status of the Local Area Connection is changed to Disabled, right-

click Local Area Connection again. 
5. Click Enable. 
6. When the Status of the Local Area Connection is changed to Enabled, close the 

Control Panel windows. 
7. Verify OrthoTrac will open on the workstation. 

 
 Verify Computers are All on the Same Workgroup 

1. From the Windows Start menu, type Control Panel. 
2. Press Enter. 
3. Click System and Security. 
4. Click System. 
5. The workgroup is displayed in the Computer name, domain, and workgroup 

settings section. 
6. To change the workgroup, click the Change settings link. 

Note: If there is more than one workgroup listed, double-click the first network group in the list 
and look for the name of the computer you are logged into. Verify the server is located in the 
same workgroup. If the server is not listed in the workgroup, click the Back button and search 
the second workgroup for the server. When the server and the computer you are logged into are 
not on the same workgroup, change the workgroup from the My Computer icon by clicking on 
the Change button on the General tab. 
 
Verify Workstations have Read, Write and Delete Permissions on the \OMS\PWSvr and 
\OMS\PWSvr\msg Folders on the Server 
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1. Double-click the This PC or My Computer icon on the Windows desktop. 
o The name of the function depends on the Microsoft operating system version 

installed on the machine. If the icons are not visible on the desktop, do the 
following to display the icons: 

i. Right-click anywhere on the desktop. 
ii. Select View. 
iii. Select Show desktop icons. 

2. Double-click the C-drive on the Server. 
o Typically mapped to U:\. This server path can be confirmed in the OMS.ini on the 

workstation. 
3. Double-click the OMS folder. 
4. Double-click the PWSvr folder. 
5. Right-click anywhere in the folder and select New > Text Document. 
6. Type test.txt as the filename. 
7. Press Enter. 
8. Right-click the newly created file and select Delete. 

Note: If any of the following happen, change the permissions on the server to grant the 
workstation user name Administrator permissions to the \OMS\PWSvr folder and subfolders 
on the server: 

o Errors are displayed when trying to create or delete the test file. 
o A message is displayed indicating the workstation does not have permission to 

access the server. 
o A prompt is displayed for a user name and password when trying to access the 

server. 
9. Repeat steps 1 through 8 for the PWSvrmsg folder. 
10. Verify OrthoTrac will now open on the workstation. 

 
Verify the Workstation is able to Ping the Server by Name 

1. From the Windows Start menu, click Start > Run. 
2. Type oms.ini. 
3. Press Enter. 
4. Make a note of the server's name in the ServerName path. 

o The server name is the information before \ORSQLEXP. 
5. Close the OMS.ini file. 
6. From the Windows Start menu, click Start > Run. 
7. Type cmd. 
8. Press Enter. 
9. Type ping <servername>. 

Note: Replace <servername> with the server's name from step 4. 
10. Verify the time on the workstation and server are the same. 


