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Overview 
This Technician’s Installation Packet (Tech Pack) outlines the responsibilities of the local 
technician, and how support can assist. This document covers recommended hardware, 
network, and software configurations. It also contains information on configuring WinOMS, a 
Sensei product, as well as migrating the data to a new server, maintaining, and backing up data 
and necessary files for WinOMS. 
WinOMS is a critical systems application that must be running every day with as little down time 
as possible. In addition to the application, the hardware is critical to ensuring the stability of an 
automated practice management system. Our hardware recommendations follow what has 
been tested. Carestream Dental is only able to test WinOMS in a limited number of 
environments. WinOMS support will work with you as best as we can if you are not following our 
recommendations, but we will be limited in modifications we can make to get WinOMS working 
in environments that do not meet the requirements listed in the current Systems 
Requirements. 
Carefully read and follow the installation instructions in the Installation Guide, and 
recommendations contained within this Technician’s Installation Guide. If you have any 
questions, contact WinOMS support. 

Technician Acknowledgement 
The local technician is fully responsible for the configuration, installation, and maintenance of 
the client's computer network. Our company does not support the installed network or its related 
issues, including printer installations or operations. 
The local technician is fully responsible for making sure the hardware is configured and the 
client is trained to save and restore a backup of the WinOMS data and all necessary files for 
WinOMS. Since there are many types of backup programs, WinOMS support does not train 
offices on configuring the backup system or restoring a database. If an office must send data to 
WinOMS support for in-house analysis, send backups on external hard drives, flash media, or 
internet transfers. No other forms of backup media are accepted for data analysis. Addendums 
to installation documents will be made, as necessary. 
The local technician is fully responsible for the support and maintenance of the client's computer 
network system. Give your clients your contact information and specific instructions to contact 
you first for system-related problems. Any questions about optimizing the network environment 
for use with WinOMS products are welcome. It is recommended that you be familiar with the 
client’s Windows operating system and carry an MCSE (Microsoft Certified Systems Engineer) 
certification or equivalent on staff. 
WinOMS representatives are highly trained and capable of assisting you to ensure a smooth 
software/hardware installation and systems upgrade. When contacting support, be sure to have 
the client’s account or phone number ready. 
Questions can be emailed directly to oralsurgerysupport@csdental.com or call support at 
800.275.4637. 
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System Requirements, Installation and Configuration 
Before installing WinOMS or migrating the data, review the following items in the Resource 
Library (gosensei.com): 

• System Requirements – Review before proceeding to ensure the hardware meets or 
exceeds the current requirements. 

o Locally Hosted or Shared Server 
▪ Locally Hosted or Shared Server System Requirements Version 9.7 
▪ Locally Hosted or Shared Server System Requirements Version 9.6 

o WinOMS Cloud 
▪ WinOMS Cloud System Requirements Version 9.7 

• Configuration Guide – Review the current configuration recommendations. 
• Installation Guide – Follow the steps to perform an upgrade or new installation. 

Self-Installation Recommendations – Downloading the Installer Files 
Beginning with version 9.7, the WinOMS Installer is available for download via the Dental 
Practice Management Software Download Service. 

1. Save the WinOMS Installer files to the server. 
2. Follow the procedures in this document to install or update WinOMS. 

Downloading the installer files: 
1. On the server, go to softwaredownload.csdental.com. The Dental Practice 

Management Software Download Service login window is displayed. 
2. Enter the Customer ID and Zip Code. Your Customer ID is between 6 and 10 digits 

and is located on the Support Schedules, Annual Contract Renewals, and any 
Invoice. 

3. Click Submit. The installer file download is displayed, along with instructions. 
4. Click Download and save the file to the default download location. 

Note: If the downloaded file is zipped (.zip), right-click and select Extract All. 
STOP! Before you proceed, verify any 3rd party vendors used by the office are compatible with 
the version of the DPMS software downloaded. It is the office’s responsibility to check with any 
3rd party Application/Software companies to ensure that it is compatible with the new version of 
DPMS/SQL software being installed. Carestream Dental is not responsible for incompatibility 
issues with 3rd party vendors. 

Licensing and Registration 
Before removing any software from the old server, copy the contents of the PWSvr folder which 
contains the license file. 
Notes: 

• This PWSVR folder is normally installed within the WinOMSCS folder on the data 
server. This location may vary if the office is using Carestream Dental Oral Imaging. 

https://gosensei.com/pages/resource-library
https://gosensei.com/pages/resource-library
https://cdn.shopify.com/s/files/1/0573/0821/7483/files/WinOMS_9.7_CR_SystemRequirements.pdf?v=1691634780
https://cdn.shopify.com/s/files/1/0573/0821/7483/files/WinOMS_9.6_System_Requirements.pdf?v=1691634780
https://cdn.shopify.com/s/files/1/0573/0821/7483/files/WinOMS_9.7_HostedSystemRequirements.pdf?v=1691634780
https://softwaredownload.csdental.com/en-US/


 
Page 3 

WinOMS Tech Pack 

OL700-01 

• Install the license file on the new server before installing the software on the 
workstations. 

• If you do not have a current copy of the license file, contact support. The support team 
can either send a copy via email or connect to the server and upload a copy. 

Installing the License File – PWSvr 
When a prompt to install the license file is displayed while installing or opening WinOMS, do the 
following: 

1. Browse to the location of the saved PWSvr file. 
2. Select the file. 
3. Click OK. 

Registering the Software 
When a prompt to register the software is displayed while installing or opening WinOMS, 
register the software using one of the following methods: 

• Register online via the internet 
• Contact support by phone 

Note: If you are unable to register the software at this time, click Cancel to continue with the 
update. You have seven days to register the product. 

To Register via the Internet 
1. Select Automatically via the Internet. 
2. Click OK. The Registration Code window is displayed while the code is generated. 
3. After the registration code is obtained, the Installation Complete window is displayed. 
4. Click Finish. 

Note: If you have registered the software more than three times, you will be required to 
contact support to receive a registration code. 

To Register by Phone 
1. Select Contact support by telephone. 
2. Click OK. 
3. Contact support using one of the following methods: 

o Call 800.275.4637. 
o Email oralsurgerysupport@csdental.com. 

4. Provide the Customer ID and Hardware ID information from the Registration window 
when contacting support. These numbers are used to generate the Registration Code. 

5. Type the registration code in the Registration Code field. 
Note: Use capital letters when typing the registration code. 

6. Click OK. The Installation Complete window is displayed. 
7. Click Finish. 

mailto:oralsurgerysupport@csdental.com
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Backup and Restore Recommendations 
This section covers recommendations for configuring a backup routine for WinOMS data and 
related files. When setting up the backup routine, review the following sections in the WinOMS 
Configuration Guide in the Resource Library for more information. 

• Backing Up Data 
• Using a Backup Checklist 
• Establishing a Backup Routine 
• Managing Files and Backup Media 

The WinOMS practice is responsible for maintaining backups of the WinOMS data. We 
recommended backing up the entire WinOMSCS folder daily to ensure the database and all 
other items pertinent to running WinOMS are backed up. Work with your hardware vendor to 
create and maintain a backup routine that is specific to your practice. 

On-premises WinOMS data is stored on the server in the following folder: 

• (ServerDataDrive):\WinOMSCS\Data 
Note: If the data was installed in a location other than the default directory, configure the 
backup system to back up the actual data location. 

Configuring the Backup for WinOMS v9.7 and Older – Sybase 
Important: Before installing or updating WinOMS, we recommend you back up any important 
data and the entire WinOMSCS folder on the server which includes the data files. WinOMS 
does not support live backups as it can interfere with auto-lock features of the software. Support 
does not provide the database password. Backups should be performed by a System 
Administrator. 

The Sybase data files are: 
• mdsdb.db 
• mdsdb.log 
• mdsdb.bak 

The network server must be configured to automatically stop and start the Sybase database 
service as part of the backup process. If the database service is not stopped, the database will 
not be backed up successfully. WinOMS does not support live backups. The database can be 
stopped and started by using Sybase Central or by using net stop and net start commands. 
We recommend using net stop and net start commands. 

• Before the backup, stop the database service using: Net stop ASANYs_SQLMDS 
• After the backup, start the database service using: Net start ASANY’s_SQLMDS 

Note: In these examples, the name of the database service is SQLMDS. Replace SQLMDS 
with the correct service name if it is different for the practice. 

https://gosensei.com/pages/resource-library
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Depending on how the local technician configures the backup system, these commands may be 
used in a variety of ways. The commands can be contained in a batch file on the server or may 
be included as additional commands the backup software automatically executes before and 
after the backup occurs. We recommend automating the process by using the commands within 
batch files and using the Windows at command to run the batch files. 

Examples: 
• at 23:59/every:m,t,w,th,f c:\Backup\Dbstop.bat 
• at 05:00/every:t,w,th,f,s c:\Backup\Dbstart.bat 

To summarize: 
1. Install and configure the backup software. 
2. Create batch files for stopping and starting the database. 
3. Use at commands to schedule the batch files to stop the database before the backup is 

scheduled to run and start the database before the office opens in the morning. 
4. Do a test run to ensure the batch files work and the backup runs successfully. 
5. Restore from a backup to ensure the backup was completed correctly. 

Installation Recommendations 
Important: Before installing or updating WinOMS, we recommend you back up any important 
data and the entire WinOMSCS folder on the server which includes the data files. 

• Purchase only fully tested devices listed in the System Requirements. 
o While some non-recommended hardware performs acceptably with WinOMS, it 

remains the responsibility of the hardware technician to maintain the 
performance of the non-recommended hardware in question. If you are unsure 
as to whether a particular device is compatible with WinOMS, email 
oralsurgerysupport@csdental.com or call support at 800.275.4637. 

• Review the enhancement features for the new version in the Release Notes and What’s 
New section of the Online Help Guide in the Resource Library. 

• WinOMS v10 requires an MSSQL license before installation. If the office does not have 
an MSSQL license, contact our sales department at Dpmssales.us@csdental.com. 

• When replacing the server, make sure the workstations can browse via UNC path to the 
new server. 

o Any password prompts must be turned off or server credentials must be entered 
to allow the workstations to connect to the server. 

• The WinOMSCS folder must be shared with full control permissions and file security 
must be set for Everyone with Full Control. 

• Set the screen resolution to 1280x1024 or higher to properly display information in 
WinOMS. If using the Electronic Medical Records (EMR) feature, the recommended 
resolution is 1440x900. 

• Configure the hardware and software firewall to open the following ports internally: 
o For offices using Sybase, open the 2638 port. 

mailto:oralsurgerysupport@csdental.com
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• For remote WinOMS login, a firewall exception is required for the dbsrv9.exe. The file 
can be located in either of the following locations depending on the operating system: 

o C:\Program Files\Sybase\SQL Anywhere 9\win32\dbsrv9.exe 
o C:\Program Files\Sybase\SQL Anywhere 9\x64\dbsrv9.exe 

Note: A firewall exception is also required for MDCS.exe. 
o File Location: Root of the WinOMSCS folder 

• The update process updates existing files, adds new files, and removes outdated 
WinOMS files on the server. For v9.x or earlier, the SQLMDS service must be running 
during the update. The process also updates the Sybase Database Engine. The 
SQLMDS services must be running to start the update. 

• A server installation creates and installs the database engine that runs the database and 
the server portion of the practice management software that connects to the database. 

• WinOMS updates must be installed on the server before the update is run on each 
workstation in the network. Workstation updates can be run simultaneously. When a 
workstation is updated, a user can log into WinOMS if needed while other workstations 
are being updated. 

WinOMS Version 9.x Sybase Instructions 
Important: Before installing or updating WinOMS, we recommend you back up any important 
data and the entire WinOMSCS folder on the server which includes the data files. 

The following instructions cover the processes for first-time WinOMS installations and updating 
existing installations for Sybase versions of WinOMS, versions 9.7 or older. Read this document 
carefully before proceeding. 

Sybase version 9 is installed on the server from the WinOMS disk or ISO file. 

• If updating existing software, follow the steps in the Updating the Server – v9.x and 
Updating Workstations – v9.x sections. 

• If performing a new installation, follow the steps in the Installing on a New Server – v9.x 
and Installing on a Workstation – v9.x sections. 

Updating the Server – v9.x 
Before beginning the update, verify the WinOMSCS folder on the server is shared with full read 
and write permissions. 

Notes: 

• If you are upgrading from a version of WinOMS prior to v9.x, the Sybase Client Drivers 
window is displayed during the client installation. Follow the instructions on the window. 
The steps are in the Installing on a New Server – v9.x section. 

• The Sybase Service cannot be running during a new server install and only installs the 
current version from the Server Side – Install selection. The Sybase Service must be 
running when selecting a Server Side – Update and after the install is completed. 
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To update WinOMS on the server: 
1. Shut down all workstations in the network and close all programs on the server. All users 

must be logged out of WinOMS. 
2. Ensure the Sybase database service is running. 
3. Navigate to the location of the ISO file uploaded by support. 
4. Right-click the ISO file and select Mount. 
5. Right-click Setup.exe and select Run as administrator. 

Notes: 
• If you have a zipped file of the disk instead of the ISO file, unzip the file. Map a path 

to the Setup.exe file. Right-click Setup.exe and select Run as administrator. 
• The installer checks the computer for Microsoft .NET Framework 3.5 Service Pack 

1 (SP1). 
o If the files are present, the installation proceeds as usual. 
o If the files are not present, the installation of SP1 proceeds automatically. After 

SP1 is installed, a prompt to restart the computer is displayed. Restart the 
computer. If the installation does not continue after the restart, repeat step 5. 

o After SP1 is confirmed or installed, the Select Component window is displayed. 

 
 

6. Select Server Side - Update. 
7. Click Next. The Server Data Drive window is displayed. 
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8. Either accept the defaults or select a drive from the Server Data Drive drop-down list 
and edit the Server Name field to match the name of the Sybase database service. 
Note: When running the install, the SQLMDS parameters can be edited to point to one 
database only. Example: To update the second database, run the update steps again 
and change the parameters to location of the second dataset: 
-n SQLMDS C:\WinOMSCS\Data2\mdsdb2.db -x tcpip 

9. Click Next. The Automatic Administrator Log-in Settings window is displayed. 

 
 

10. Select Use Automatic Administrator Log-in. 
11. The User Name field defaults to the Windows login name. Enter the corresponding 

password. 
Notes: 
• The user must have administrator privileges. 
• If you do not want to take advantage of the Automatic Administrator Log-in 

feature, you must manually log into the server to run WinOMS. 
12. Click Next. A message is displayed stating the software is ready to be installed. Allow 

the update to run. 
13. Click Finish. A message is displayed stating the server installation is complete. 
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14. Click OK. 
15. Click Exit. 

You can now update the workstations. 

Updating Workstations – v9.x 
To update WinOMS on a workstation: 

1. Navigate to the location of the ISO file. 
2. Right-click the ISO file and select Mount. 
3. Right-click Setup.exe and select Run as administrator. 

Notes: 
• If you have a zipped file of the disk instead of the ISO file, unzip the file. Map a path 

to the CSInstaller folder. Right-click Setup.exe and select Run as administrator. 
• The installer checks the computer for Microsoft .NET Framework 3.5 Service Pack 

1 (SP1). 
o If the files are present, the installation proceeds as usual. 
o If the files are not present, the installation of SP1 proceeds automatically. After 

SP1 is installed, a prompt to restart the computer is displayed. Restart the 
computer. If the installation does not continue after the restart, repeat step 3. 

o After SP1 is confirmed or installed, the Select Component window is displayed. 
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4. Select Client Side, and I understand that the client side of WinOMS v9.7 only runs 
on Windows 7, 8.1 and 10. 

5. Click Next. The Target Directory window is displayed. 

 
 

6. Either accept the default or edit the path in the Target Directory field. 
o The target directory is the location where the update should be installed. 

7. Click Next. The WinOMS Version 9.7 Update window is displayed. 
8. Click Finish. The Status of WinOMS 9.7 Client Update window is displayed while the 

update is running. A message is displayed when the installation is complete. 
9. Click OK. 
10. Click Exit. 
11. Repeat the steps to update WinOMS on each computer in the network. 

Installing on a New Server – v9.x 
To install WinOMS, version 9.x, for the first time, on a new server you must install the software 
in the following order: 

1. Install WinOMS on the server. 
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2. Install WinOMS on the workstations. 

Installing on a Server – v9.x 
During a new installation, WinOMS files are copied to the hard drive of the server. A new 
installation also installs the Sybase Network Database Server, version 9.7, on the server. 

Note: The Sybase Services cannot be running during a new server install and only installs the 
current version from the Server Side – Install selection. The Sybase Services must be running 
when selecting a Server Side – Update and is run after the install is completed. 

1. Shut down all workstations in the network and close all programs on the server. All users 
must be logged out of WinOMS. 
Note: The server installation requires the Sybase license included in the WinOMS 
software. 

2. Right-click the ISO file and select Mount. 
3. Right-click the Setup.exe and select Run as administrator. 

Notes: 
• If you have a zipped file of the disk instead of the ISO file, unzip the file. Map a path 

to the Setup.exe file. Right-click Setup.exe and select Run as administrator. 
• The installer checks the computer for Microsoft .NET Framework 3.5 Service Pack 

1 (SP1). 
o If the files are present, the installation proceeds as usual. 
o If the files are not present, the installation of SP1 proceeds automatically. After 

SP1 is installed, a prompt to restart the computer is displayed. Restart the 
computer. If the installation does not continue after the restart, repeat step 3. 

o After SP1 is confirmed or installed, the Select Component window is displayed. 

 
 

4. Select Server Side – NEW Install. 
5. Click Next. The Server Data Drive window is displayed. 
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6. Either accept the defaults or select a drive from the Server Data Drive drop-down list 
and edit the Server Name field to match the name of the Sybase database service. 

7. Click Next. The Automatic Administrator Log-in Settings window is displayed. 

 
 

8. Select Use Automatic Administrator Log-in. 
9. The User Name field defaults to the Windows login name. Enter the corresponding 

password. 
Notes: 
• The user must have administrator privileges. 
• If you do not want to take advantage of the Automatic Administrator Log-in 

feature, you must manually log into the server to run WinOMS. 
10. Click Next. A message is displayed stating the software is ready to be installed. 
11. Click Finish. A message is displayed stating the install folder must be shared with full 

access to all users. 
12. Navigate to the WinOMSCS folder on the server. Share the folder with full read and 

write permissions. 
13. Return to the message and click OK. The Sybase OEM Network Database Server – 

Welcome window is displayed. 
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Note: When installing on a 64-bit operating system, such as Microsoft Windows Server 
2008 64-bit, the Sybase OEM Network windows are not displayed. The Sybase drivers 
are installed, before a prompt to restart the computer is displayed. 

14. Read the information on the Welcome window and click Next. The Sybase OEM 
Network Database Server - Select Components window is displayed. 

 
 

15. By default, all Sybase components are selected. Do not change these selections. Click 
Next. The Sybase OEM Network Database Server - Start Installation window is 
displayed. 

16. Click Next. The Sybase OEM Network Database Server window displays the progress 
of the installation. This window remains open during the Sybase installation. A message 
is displayed when the installation is complete. 

17. Click Finish. A prompt to restart the computer is displayed. 
18. Click OK to restart the computer. After the installation is complete, a prompt to install the 

license file is displayed. 
19. Follow the steps in the Installing the License File section to install the license file. 
20. Follow the steps in the Registering the Software section to register the software. 

Creating a Database Service – Sybase 
After installing WinOMS on the server, you must create a database service in Sybase Central. 

1. Double-click the Sybase Central icon on the desktop. The Sybase Central window is 
displayed. 



 
Page 14 

WinOMS Tech Pack 

OL700-01 

 

 

 

2. Click Adaptive Server Anywhere 9 in the Folders list and select the Services tab in 
the right pane. The New Services Button is displayed above the Folders list. 

3. Click the New Services button. The Create a New Service wizard is displayed. 

 
 

4. Type SQLMDS in the field and click Next. A prompt to select a service type is displayed. 
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5. Select Network Database Server and click Next. 
6. Click Next to accept the default selection. A prompt to specify parameters is displayed. 
7. Type -n SQLMDS (ServerDataDrive):\WinOMSCS\Data\mdsdb.db -x tcpip and click 

Next. 
o Replace (ServerDataDrive) with the server drive letter. 
o A prompt to select the account service is displayed. 

8. Select Local System Account. Ensure the Allow service to interact with desktop 
option is selected and click Next. 

9. Select Automatic and click Next. 
10. Click Finish. The Sybase Central window with the SQLMDS service is displayed. 

 
 

11. Right-click the SQLMDS service and click Start to start the service. A green light is 
displayed before the SQLMDS service name. 

12. Restart the v9.7 update following the steps in the Updating the Server – v9.x section. 

Installing on a Workstation – v9.x 
Note: The server installation must be complete before installing WinOMS on the workstations. 

Updating v9.x on an Existing Workstation 
1. Verify the server is running. 
2. Log into WinOMS on the workstation. A prompt is displayed stating it has detected a 

new version of the software and asks if you want to update now. 
3. Click Yes to proceed with the update. 

o If the update does not run automatically, follow the steps in the next section to 
install v9.x. 

Installing v9.x on a New Workstation 
1. Verify the server is running. 
2. Navigate to the location of the ISO file. 
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3. Right-click the ISO file and select Mount. 
4. Right-click the Setup.exe and select Run as administrator. 

Notes: 
o If you have a zipped file of the disk instead of the ISO file, unzip the file. Map the 

path to the CSInstaller folder. Right-click Setup.exe and select Run as 
administrator. 

o The installer checks the computer for Microsoft .NET Framework 3.5 Service 
Pack 1 (SP1). 

▪ If the files are present, the installation proceeds as usual. 
▪ If the files are not present, the installation of SP1 proceeds 

automatically. After SP1 is installed, a prompt to restart the computer is 
displayed. Restart the computer. If the installation does not continue 
after the restart, repeat step 4. 

After SP1 is confirmed or installed, the Select Component window is displayed. 

 
 

5. Select Client Side, and select I understand that the client side of CS WinOMS v9.7 
only runs on Windows 7, 8.1 and 10. 

6. Click Next. The Target Directory window is displayed. 
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The Target Directory defaults to C:\WinOMSCS\ and should not be changed. 

7. Click Next. The WinOMS Version 9.7 Installation Finish window is displayed. 
8. Click Finish. The Sybase Client Drivers window is displayed. 
9. Enter the server IP address. 

• If you use static IP addresses on the workstation, enter the IP address of the current 
workstation. 

• There will be fields to enter both server IP and workstation IP addresses. 
10. Click Next. The Sybase Client Drivers - Start Installation window is displayed. 
11. Click Next. A message is displayed stating the Sybase client drivers have been 

successfully installed. 
12. Click Finish. The Status Messages window is displayed, indicating the progress of the 

installation. When the installation is complete, a prompt to restart the computer is 
displayed. 

13. Click Yes to restart the computer. After the installation is complete, the WinOMS icon is 
displayed on the desktop. 

14. Repeat the steps to install WinOMS on each computer in the network. 

Migrating the Data for Sybase Versions Only 
• Download the WinOMS install files prior to performing the Sybase migration to a new 

server. See the Self-Installation Recommendations – Downloading the Installer Files 
section for steps on downloading the installation files. 

• Confirm the number of databases to be updated using one of the following methods. 
Sybase: 

o On the old server, open Parameters in Sybase Central. 
o Verify the databases in the ODBC settings. If multiple databases exist, the 

databases will be labeled mdsdb and mdsdb1. 
▪ If there are multiple databases follow the steps in the Configuring Dual 

Database after a Server Migration – v9 section. 
o If possible, keep the new server name and IP address the same as the old 

server. 
o If possible, ensure the WinOMS folder on the new server is shared with the same 

name as the old share, usually MDCS or WinOMSCS. 
• Set sharing and security permissions on the new data folder to Full Control for 

Everyone with full read and write permission. Do the same for Domain users and 
Authenticated Users groups, if used. 
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Demoting the Old Server – v9.x 
To demote the old server: 

1. Double-click the Sybase (SQL) Central icon on the desktop. 
2. Double-click Adaptive Server Anywhere 9. 
3. Select the Services tab on the upper-right side of the pane. 
4. Right-click SQLMDS and select Stop. 
5. Right-click SQLMDS and select Properties > General. 
6. Set Startup type to Disabled. 
7. Click OK to save changes and exit Sybase Central. 
8. Right-click the PracticeWorks Server icon (gold key) in the task bar and select Exit 

PracticeWorks Server. 
9. Copy the license files pwlf.dat and store it on the desktop of the new server. Rename 

the PracticeWorks Server icon. The license file is located in the PWSvr folder. 
o Open the PWSvr directory on the server, for example, F:\WinOMSCS\PWSvr. 

Rename the pwsvr.exe file to pwsvr.exe_OLD. 
10. Locate the PWSvr and MDCSRegistered folders in the WinOMSCS folder on the server 

and rename them to PWSvr_OLD and MDCSRegistered_OLD. 
11. Copy the entire WinOMSCS folder from the OLD SERVER to the NEW SERVER. The 

WinOMSCS folder MUST be on the root of the drive, for example, E:\WinOMSCS\. 
12. Turn off the old server or remove the server from the network. 

Promoting the New Server – v9.x 
To promote the new server: 

1. Share the WinOMSCS folder copied from the old server. Use the same share name that 
was used on the old server, usually WinOMSCS or MDCS. 

2. Set the Sharing and Security permissions on the WinOMSCS or MDCS folder as 
follows: 

o Set permissions for Everyone to Full Control. 
o If Domain Users or Authenticated Users Groups are used, set permissions to 

Full Control. 
3. Ensure .NET 3.5 Framework in Server Manager > Features is enabled. 

o A reboot is required after .NET 3.5 Framework is installed or enabled. 
4. Install WinOMS as per the instructions in the Installing on a Server – v9.x section. 
5. After the computer restarts during the installation, click OK on the prompt stating the 

mdsdb file is present. This step ensures the data WILL NOT be overwritten. 
6. When the Server-Side install is complete, configure the Sybase SQLMDS Service and 

start the database service following the steps in the Configuring Sybase Services After 
Server Migration – v9.x section. If an error is generated when starting the SQLMDS 
service, follow the steps in the Unknown Error Starting SQL Service in Sybase section to 
resolve the issue. 
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7. Verify the PracticeWorks Server icon (gold key) is running in the system tray. 
o If the gold key is not running, make sure the PWClient path on the server is set 

to a drive letter path. Follow the steps to set the path in the Updating the 
PWClient License Path section, then double-click the PWSvr.exe file to launch. 

8. If the name of the new server is different from the old server, run the cstoolkit utility to 
update the server directory. Follow the steps in the Updating the Server Directory Using 
CSToolkit section. 

9. Add an exception for any software or hardware firewalls. The file to be excluded or 
allowed is the dbsrv9.exe located at: 

o On 32-bit operating systems: 
i. C:\Program Files\Sybase\SQL Anywhere 9\win32\dbsrv9.exe 

o On 64-bit operating systems: 
i. C:\Program Files\Sybase\SQL Anywhere 9\x64\dbsrv9.exe 

10. Configure the firewall to open the 2638 port for UDP. 
11. If updating the software version as well as installing the new server, run the update 

again to update the database to the current version installed on the server. Follow the 
steps in the Updating the Server – v9.x section. 

12. Configure nightly backups for the new server. 
Notes: 

o WE DO NOT SUPPORT LIVE BACKUPS. 
o The Sybase SQL service for the database is REQUIRED to be STOPPED to 

ensure a valid copy of the database is made during backup process. 
o Online backup services are supported as long as the Sybase SQL service is 

STOPPED prior to the backup initiating. 
o Follow the steps in the Configuring the Backup for WinOMS v9.7 and Older – 

Sybase section to stop and start the database service. 

Configuring Sybase Services after a Server Migration – v9.x 
1. Double-click the Sybase Central or SQL Central icon on the desktop. 
2. Double-click Adaptive Server Anywhere 9. 
3. Select the Services tab. 

o If SQLMDS is listed in the services, verify it has a green light. 
o If SQLMDS is not listed in the services, continue to the next steps. 

4. Select File > New Service. 
5. Type SQLMDS in the field and click Next. 
6. Select Network Database Server and click Next. 
7. Confirm the Sybase executable path is correct for the operating system on the server. 

o For 32-bit: C:\Program Files\Sybase\SQL Anywhere 9\win32\dbsrv9.exe 
o For 64-bit: C:\Program Files\Sybase\SQL Anywhere 9\x64\dbsrv9.exe 
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8. Type -n SQLMDS (ServerDataDrive):\WinOMSCS\Data\mdsdb.db -x tcpip in the 
Parameters field. 

o Replace (ServerDataDrive) with the server drive letter. 
Note: Only complete steps 9 and 10 if the client uses ePrescriptions. If the client does not 

use ePrescriptions, skip to step 11. 
9. Click the end of the SQLMDS WinOMS string and press Enter to drop to the next line. 
10. Type -xs http (port=8081) on the new line. Do not cut and paste. The string must be 

entered manually. 
11. Select both the Local System Account and Allow service to interact with desktop 

options. 
12. Select Automatic Startup. 
13. Select Start services now. 
14. Click Finish. The SQLMDS service is now running. A green light is displayed before the 

SQLMDS service name. 

Configuring Dual Database after a Server Migration – v9.x 
1. Verify everyone is logged out of each WinOMS database before doing a server 

migration. 
2. Verify the number of databases to be transferred to the new server. 
3. If the old server is accessible, verify the ODBC settings for each database. These 

settings can be used to configure the ODBC settings on the new server. 
4. Verify each database is included in the Sybase Central parameters. 

o When updating, verify all databases are updated to the same version. 
Example: If updating from v9.6 to v9.7, verify all databases are updated to the 
same version before continuing to work in WinOMS. 

o The first time the update is run, the first database, mdsdb, is updated. Run the 
install a second time. During the install, click the ellipses. Then navigate to and 
select the Data2 directory in the Target Directory field to update the second 
database, mdsdb2. 

 
 

5. Ensure a copy of each database is accessible on the new server. 
6. Each database will have its own license file. Transfer the license files to the new server. 

Contact support for the licenses if replacement files are needed. 
7. After completing the migration, test logging into WinOMS for each database. 

Follow the instructions in the next sections to configure the ODBC and Registry edits required 
on the new server after a server migration when using multiple databases. 
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Licensing for Dual Databases – v 9.x 
In a dual database configuration, each database is required to have its own license file. This 
section covers the steps for configuring files for the second database. 

1. Stop the service SQLMDS. 
2. Create a new folder on the server named Data2; for example, C:\WinOMSCS\Data2. 
3. Copy the new database to the Data2 folder; for example, mdsdb2.db. 
4. Open Sybase Central from the desktop. 
5. Select the Services tab. 
6. Right-click SQLMDS (service name) and select Properties. 
7. Select the Configuration tab. 
8. Edit the parameters to add the path to the second database. Example: Type  

-n SQLMDS c:\WinOMSCS\Data\mdsdb –x tcpip c:\WinOMSCS\Data2\mdsdb2. 
9. Click Save. 
10. Change the Log File setting in Sybase Central. 

• Go to Tools > Adaptive Server 9 > Change Log File Settings. 
• Browse to mdsdb2 on the server. 
• Accept all default settings. 
• Set the path for the log file to c:\WinOMSCS\Data2\mdsdb2.log. 

11. Start the service SQLMDS. 

Installing the License File – v9.x 
1. Copy the license file into the PWSvr folder. 

• If the office has a dual database setup, copy the license file for each database into 
the PWSvr folder in the Data and Data2 folders. 

2. Open the PracticeWorks server and note the ID numbers. 
3. Go to Start > Run and type regedit. 
4. Press Enter. 
5. Go to HKEY_LOCAL_MACHINE > Software > PracticeWorks. 
6. Right-click PWRegSvrLicFileID. 
7. Select Modify. 
8. Set Value to 1. 

Note: This is the ID number for the first database. Complete the following for the second 
database license file. 

9. Right-click the PracticeWorks folder under HKEY_LOCAL_MACHINE > Software. 
10. Click New. 
11. Select String Value which adds an entry in the right window. 
12. Rename the new entry to PWRegSvrLicFileID. 
13. Right-click the new PWRegSvrLicFileID entry. 
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14. Select Modify. 
15. Set Value to 2. 
16. Close the Registry. 
17. Log into each instance of WinOMS to test. 

Creating Registry Edits 
Perform the following steps while still in the Registry Editor: 

1. Open HKEY_LOCAL_MACHINE > Software > PracticeWorks. 
2. Highlight the PracticeWorks key and export it to the desktop with a name to identify the 

registry settings for the first database, for example, database1. 
3. Go back to HKEY_LOCAL_MACHINE > Software > PracticeWorks. 
4. Change the DSN to MDCS2. 
5. Modify the PWRegSvrLicFileID value to equal 2 and export it to the desktop with a 

name to identify the registry settings for the second database, for example, database2. 

Configuring ODBC Settings 
1. Go to Start > Settings > Control Panel > Administrative Tools > Data Sources 

(ODBC). 
2. Select the System DSN tab. 
3. Click Add. 
4. Create a data source named MDCS2. 
5. Configure the ODBC to show the second database name under the Database tab. 
6. When the migration is completed, double-click the registry export on the desktop for the 

first database. Then double-click the WinOMS icon to log into the software. 
7. Log out of the first dataset. 
8. Double-click the registry export on the desktop for the second database. Then double-

click the WinOMS icon to log into the software.to access the second dataset. 

Install Client Side on Server – v9.x 
1. Navigate to the location of the ISO file. 
2. Right-click Setup.exe and select Run As Administrator. 
3. Select Client Side, and I understand that the client side of WinOMS v9.7 only runs 

on Windows 7, 8.1 and 10. 
4. Click Next. 
5. Select the drive path where the Server Side was installed, for example, 

D:\WinOMSCS\. 
6. Click Finish. 
7. After the installation is complete, log into WinOMS to test. 
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Configuring Workstations after a Server Migration – v9.x 
• If the name of the new server is different than the old server, the PWClient path for all 

workstations must be updated. Follow the steps in the Updating the PWClient License 
Path section. 

• If the practice has remote office locations connecting to the server via VPN, 
update the server IP address in the ODBC data connection on the remote 
workstations. 

o On a 32-bit workstation: 
i. Verify the TCP/IP option is selected in Control Panel > Administrative 

Tools > Data Sources (ODBC) > System DSN tab > Configure MDCS 
> Network tab. 

ii. Type Host=xxx.xxx.xxx.xxx in the field, where X is the static IP address 
to the WinOMSCS folder on the server. 

o On a 64-bit workstation: 
i. Navigate to C:\Windows\SysWow64\Odbcad32.exe. 
ii. Verify the TCP/IP option is selected in Control Panel > Administrative 

Tools > Data Sources (ODBC) > System DSN tab > Configure MDCS 
> Network tab. 

iii. Type Host=xxx.xxx.xxx.xxx in the field, where X is the static IP address 
to the WinOMSCS folder on the server. 

Third Party Products 
WinOMS integrates with multiple third-party vendors. As such, some configuration for clients 
that use these products may be required. 
Note: This listing is not a complete list of third-party integrated products used by the office. It is 
used to aid with the most common issues. For a more comprehensive list of third-party products 
integrated with the software, see the System Requirements. 

List of Third Party Services Compatible Version 9.x 
For an updated listing of third party authorized Carestream Dental partners and their contact 
information, visit the Authorized Partners page on our website. 
The following list identifies the Carestream Dental authorized partners that offer services that 
work with WinOMS v9.x. 
Note: This information is subject to change. 

https://gosensei.com/pages/authorized-partners
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Note: MTM (PEARL) v9 and v10 are on-premises only. 

Related Documentation and Resources 
Additional information available in the Resource Library (gosensei.com): 

• Initial Training Workbook 
• Online Help 
• Release Notes 
• Link to our virtual agent, Cassidy 

o https://gosensei.com/pages/support-winoms 
Cassidy is Carestream Dental’s AI-powered virtual agent offering 24/7/365 online 
customer support. When you need a quick step-by-step guide or question on 
product needs, information is instantly available via Cassidy. 

• Link to the Carestream Dental Institute: carestreamdental.com/cdi 

https://gosensei.com/pages/resource-library
https://gosensei.com/pages/support-winoms
http://carestreamdental.com/cdi
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Installation Troubleshooting – WinOMS Sybase v9.x Versions 
Unknown Error Starting SQL Service in Sybase 
Issue: When trying to start the database service, the following message is displayed: 
The service ‘SQLMDS’ has generated an unknown error. 

Cause: This error is generated when the path to the mdsdb.log file is incorrect in Sybase. 
Solution: Update the path in the Server Directory and the PWClient file. 

1. Open Sybase Central. 
2. Select the Utilities tab. 
3. Select Change log file settings. 
4. Click Next. 
5. Browse to the database file, (ServerDataDrive):\WinOMSCS\Data\mdsdb.db. 
6. Highlight the file and click Open. 
7. Click Next. 
8. Note the log file path if the drive letter is incorrect. 
9. Click Next. 
10. Select the Maintain the following transaction log file option. 
11. Correct the log file path drive letter. The drive letter can be verified in the Sybase 

Central configuration on the desktop of the new server. 
12. Click Next. 
13. Verify the Maintain the following mirror log file option is NOT selected. 
14. Click Next. 
15. Accept the defaults. 
16. Click Finish. 

 
Updating the Server Directory Using CSToolkit 

1. Launch the cstoolkit.exe in the root of the WinOMSCS folder. 
o (ServerDataDrive):\WinOMSCS\cstoolkit.exe. 

2. Select the Server Directory Assignment Tool option. 
3. Click the green arrow. 
4. Select the practice name from the drop-down list. 
5. Enter the correct UNC path to the WinOMSCS directory. 

o For example: \\Server\WinOMSCS\ 
6. Click Apply. 
7. Click OK. 
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Updating the PWClient License Path 
1. Open PWClient. 

o On 32-bit operating systems: 
i. Go to Start > Run. 
ii. Type PWClient. 
iii. Press Enter. 

o On 64-bit operating systems: Go to C:\Windows\SysWow64\PWClient.exe. 
2. Click Options. 
3. Set the path. 

o On the server ONLY, set to driver letter path to PWSvr.exe, for example, 
(ServerDataDrive):\WinOMSCS\PWSvr\. 

o On the workstations, set the path to the new UNC path to the gold key on the 
server; for example, \\Server\MDCS\PWSvr\. 

4. Click OK. 
5. Click Close. 
6. Log into WinOMS. 

 
Unable to locate .INF File 
Issue: This error may occur when attempting to install WinOMS from a mapped drive. 
Causes: 

• User Account Control (UAC) is turned on. 
• UAC is turned off, but the workstation has not been rebooted. 
• An improperly mapped drive. 

Solution: If running Windows 7, 8, or 10, User Account Controls (UAC) must be turned off 
and the workstation must be rebooted prior to installing WinOMS. 

1. Click Start. 
2. Click Run. 
3. Browse to server. 
4. Browse to the _CSInstaller folder located in the WinOMSCS\Auto_Update folder. 

o For example: \\Server\MDCS\auto_update\_CSInstaller 
5. Map a network drive directly to the _CSInstaller folder. 
6. Browse through the newly created mapped drive and double click the Setup.exe file. 

The installation wizard is displayed. 
7. Select Client Side. 
8. Click Next. 
9. Enter the Target Directory where WinOMS is to be installed. 
10. Click Next. 
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11. Click Finish. 
 
Error Code 100 
Issue: Error 100 indicates a connectivity issue. It may be one or more computers or the entire 
network. 
Solutions: 

• Verify the workstation can browse to the server without requesting the Windows 
username and password. 

o Ping the server at the Windows command prompt to ensure connectivity and no 
packets are being lost. 

o If unable to ping the server, check the network settings and turn off the Windows 
feature so the Windows username and password are not being prompted for at 
login. 

• Verify it is not a DSN issue on the network. Verify the PracticeWorks data values in the 
registries are correct: 
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\PracticeWorks. 

• Verify the ODBC settings are correct and the TCPIP field is checked and 
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\PracticeWorks 
on the Network tab. Test connection in ODBC for connection if one workstation. 

• If all workstations are receiving Error Code 100, verify the Sybase Service, SQLMDS, 
is running and a green light is displayed. 

o Open Sybase Central, the half gold wheel icon on server’s desktop, to verify it is 
running. 

• Verify users are connected to the correct database. 
o Open the CS Toolkit.exe in the WinOMS folder in basic mode. 
o Verify the Practice Name and UNC Path are correct. Follow the steps in the 

Updating the Server Directory Using CSToolkit section. 
o At the command prompt run dblocate to ensure there is not another database 

running on the same network which can cause a conflict. 

• If all the settings are correct, reboot server. Next, log in WinOMS client on server if the 
WinOMS icon is present or test logging in on a client workstation running WinOMS. 

 
Database Specified in the ODBC cannot be Located 
Issue: This error is caused when the Database name in the registry does not match the 
Database name in SQL Central. This can happen during a failed or cancelled server side 
update. 
Solution: 

1. Go to Start > Run and type regedit. 
2. Press Enter. 
3. Click + to expand HKEY_LOCAL_MACHINE. 
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4. Click + to expand SOFTWARE. 
5. Click + to expand WOW6432NODE (only on 64 bit OS). 
6. Click to highlight PracticeWorks. Do not expand. 
7. Right-click DSN in the right-side panel and click Modify. 
8. Change name from MDSSETUP to MDCS. 

If the steps above, do not resolve the issue proceed to the following steps: 
1. Double-click the Sybase/SQL Central icon on Server Desktop. 
2. Click Adaptive Server Anywhere 9 on either side of the screen. 
3. Select the Services tab. 
4. Right-click SQLMDS. 
5. Click Properties. 
6. Click Configuration. 
7. Verify the parameters for the executable. 

Note: Verify the database name and data drive. 

 

 
8. Launch ODBC by typing the following in the run or search programs and files window 

and pressing Enter: 
o On 32-bit operating systems: odbcad32.exe 
o On 64-bit operating systems: C:\windows\Syswow64\odbcad32.exe 

9. Select the User or System DSN tab. 
10. Locate and highlight MDCS. 
11. Click Configure. 
12. Select the Database tab. 
13. Verify the Database Name. 
14. Select the Network tab. 
15. Verify the Server IP Address. 
16. Click OK. 
17. Repeat steps 1-7. 

Note: Make any changes to the Database Name or Drive, if needed. 
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18. Click File. 
19. Click Exit. 

 
Error getting Posting Office ID 
Issue: This error may occur when logging into WinOMS after an update. 
Cause: The root cause is an incorrect or missing registry entry. 
Solutions: 

• Usually re-running the client side install to update the registry resolves the issue. 
• If the error persists, manually enter the following registry entry: 

o 32-bit Windows Operating System: Location HK_Local_Machine > Software > 
PracticeWorks - String Value LastPostingOffice Value = 1 

o 64-bit Windows Operating System: Location HK_Local_Machine > Software > 
WOW6432Node\PracticeWorks - String Value LastPostingOffice Value = 1 

▪ The Value must be equal to the ID of the last office who logged out of 
WinOMS. 

• If value 1 does not resolve issue, change to value 2 and try again. 
• Continue until the correct office ID is selected. 
• The rule of thumb is to set the Value to the number of office 

locations the practice has. 
 
No DBMS Specified 
Issue: This error is caused by missing information in the registry. 
Solution: 
Rerun the client-side update. If this does not resolve the issue, edit the registry as follows: 

1. In the registry, navigate to HKEY_Local_Machine. 
2. Expand the Software folder. 
3. Expand Syswow632Node. 
4. Click the PracticeWorks folder. 
5. Right-click in a blank section of the right-side of the screen, select New > String Value. 
6. Type DBMS as the name of the new String Value. 
7. Press Enter. 
8. Right-click DBMS. 
9. Click Properties. 
10. Enter ODBC as the description. 
11. Click OK. 
12. Close the Registry Editor. 
13. Log into WinOMS. 
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If the above does not resolve issue: 
• On more recent versions of Windows, it may be necessary to export the contents of the 

PracticeWorks registry key from HKEY_LOCAL_MACHINE > Software > 
Wow6432Node > PracticeWorks and import them into HKEY_CURRENT_USER > 
Software > PracticeWorks. 

• For a new workstation open the ODBCs on the workstation and confirm the settings are 
correct. 

 
Unable to Start/Start NexGen services. An unknown problem occurred. 
Issue: This error may be displayed during a v9 server update if the update fails. The install is 
unable to proceed until this error is resolved. 

 
 
Solution: 
Check and resolve the following items: 

1. Check the mdssetup.log located on the root of the C drive on the server for specific 
errors. 

2. Determine if a WinOMS SQL Server Instance is present under Windows Control 
Panel. 

o If more than one instance of SQL Server (WINOMS) is present, uninstall the 
WinOMS SQL Server instance as it will conflict with the v9 update. 

 
3. Verify whether a live WinOMS backup is running. 
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o If a live backup is running, turn the feature off and run the update. Live backups 
are not supported and cannot be running during an update. 

4. Check if Pearl is installed on the server and if the services are running. 
o If Pearl is installed, the Pearl Mobile icon will be on the server desktop.

 
o If the services are running disable the Pearl services to proceed with the update. 

i. Click Start. 
ii. Click Settings. 
iii. Click Control Panel. 
iv. Click Administrative Tools. 
v. Click Services. 

5. Verify the following services are installed: 
o PracticeWorks Pearl Adapter Host 
o Carestream Application Server 
o MTM Mobile for PracticeWorks 

Note: Stop the services in the order listed above. To stop the services, right-click on the 
service name and click Stop. 

o Remember to restart the services after the WinOMS update is complete. 
6. Restart the services in the reverse order as follows: 

o MTM Mobile for PracticeWorks 
o Carestream Application Server 
o PracticeWorks Pearl Adapter Host 

i. Launch Practice Mobile Admin from the desktop. 
ii. Select the Services tab. 
iii. Click Test Connection. The connection response for both the Cloud and 

Data Adapter should be OK Connectivity. 
5. Verify .net framework 3.5 is turned on. 

o Search Windows Control Panel > Programs and Features. Click Turn 
Windows features on or off. Verify .NET Framework 3.5 is selected. If it is not, 
select .NET Framework 3.5. 
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6. Turn off any Windows Firewalls. Disable Webroot if it is installed. Ensure UAC is turned 
off. 

7. Retry the WinOMS update. 
8. Remember to restore any necessary Windows Firewalls, plus enable Webroot and 

UAC, after the update completes. 
9. Ensure the DSN registry entry is set to MDCS. If it is set to anything else, modify the 

value to MDCS. 
Note: When an update fails, the registries may change. 
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Directories To Configure on a New Computer – On-Premises 
Configurations 
The following settings need to be configured in WinOMS on a new on-premises computer or 
when the server name has been changed after a migration every workstation will need updated 
with these settings. 
 
Server Directory 

1. Go to Tables > Practice > Practice Preferences > Miscellaneous. 
2. Update the Server Directory to \\(NewServerName)\MDCS\. 

o This can prevent a common error, Invalid Letter Directory. The error may occur 
during the mail merge process when this directory is incorrect. 

 
Output Directory (Data Export) 
This feature is optional and may not be configured if the office does not use the Data Export 
feature in the software. To enable the feature, do the following: 

1. Go to Tables > Practice > Practice Preferences > Miscellaneous. 
2. Select Enable Data Export. 
3. Verify the path in the Output Directory field is set to the Export folder on the data 

server. For example, \\(NewServerName)\MDCS\Export\. 
o If this path is incorrect, the feature will be disabled. 

 
Image Directory 

1. Go to Utilities > My Computer Settings. 
2. Set the path in the Directory field to the Images folder on the data server, for example, 

\\(NewServerName)\MDCS\Images\. 
Note: Copy this path from a working computer and not the Server. If this path is 
incorrect, the office will not be able to scan images, retrieve images or save attachments 
through WinOMS. 

 
PWClient 
Update the PracticeWorks Server Path in the PW Client file. Follow the steps to set the path 
in the Updating the PWClient License Path section. 
If this path is not updated, the office may receive one or more of the following license errors 
when logging in WinOMS: 

• Pwsvr.exe is not Installed Correctly 

• License server not found -1 

• A prompt may be displayed to browse to the license server. 
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ODBC 
If the IP address or server name is incorrect in the ODBC Data Source Administrator, the 
office may receive one or more of the following connection errors: 

• Error code 100 
• Database or Server not found 

To resolve the issue, edit the ODBC as follows: 
1. Open the ODBC, C:\Windows\SysWOW64\odbcad32.exe. 
2. Select the System DSN tab. 
3. Select MDCS. 
4. Click Configure. 
5. Select the Network tab. 
6. Verify server IP address is correct. 
6. If the Network tab has the IP address for the old server, replace the information with the 

IP address for the new server or server name, for example, host = (server IP address). 
o This field is optional and can be left blank. 

7. Verify TCP/IP is selected on the Network tab. 
8. Click OK. 

 
Data Directory 
Edit the following if the customer is using the ePayments module. 

1. Go to Tables > Practice > Practice Preferences > Financial. 
2. Update the path in the Data Directory field. 

o The path should point to \\(NewServerName)\MDCS\ICCPS. This is the main 
path that is used for ePayments, ePayments Secure and Payment Manager 
for conversion purposes. 

o If this path is incorrect the office will be unable to use ePayments. 
 Contact support if assistance is needed configuring the ePayments module. 


